1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed Thread Prefix permissions incorrect when using "Test Permissions"

Discussion in 'Resolved Bug Reports' started by Markus, Nov 12, 2011.

  1. Markus

    Markus Member

    It seems like "Test Permissions of User" does not make you to use the user permission when using prefixes.
    For example, if you make a prefix that is Admin-only, you will still see that prefix when testing permissions of an user that has the mere "Registered" group membership.
    I believe this is incorrect and is indeed a bug in the software.
  2. Mike

    Mike XenForo Developer Staff Member

    It's highly unlikely this will change. The documentation may change to reflect that.

    The approach is very different from what the permission tester is for (group and node-style permissions).
  3. Markus

    Markus Member

    Fair enough, a change in documentation will be enough, for now it was just a bit unclear whether it should have worked as I thought or not.
  4. Kier

    Kier XenForo Developer Staff Member

    Documentation updated.
  5. mrGTB

    mrGTB Well-Known Member

    This doesn't sound right to me at all, the Prefix then is inheriting permission from 1st usergroup if I'm reading this correctly. IE: Mods, Admins and Members are all in the "registered" primary user-group first, then in others 2nd like Mod and Admin. Hence why Prefixes are not working as they really should based on permission tick boxes checked.

    Not sure if I am reading this thread right, if I am this is wrong. There's no point having permissions on Prefixes then, because they have no real effect in doing anything.
  6. Jeremy

    Jeremy XenForo Moderator Staff Member

    Prefixes have permissions as long as your in a group. I can't set a prefix in the open bug reports because I'm not in one of the groups that have it permitted. The tester as described above is to test how your node permissions are set up and such.
  7. mrGTB

    mrGTB Well-Known Member

    OK, I must have read what he was saying wrong. Found it hard to grasp what he was saying exactly anyhow.

Share This Page