Cannot reproduce The Word Stemming setting at None does not seem to apply

Affected version
2.1

beerForo

Well-known member
Please see here, thanks:
 

Mike

XenForo developer
Staff member
I have tried this with various versions of Elasticsearch and I can't reproduce it.

However, what I did notice with one particular version I tested, it didn't display back the index configuration correctly. Specifically, it would display it back as not having stemming enabled even when it was enabled. If you then saved it (with no stemming selected) and rebuilt the index, it would behave correctly though. This happened in 6.4.0; I wasn't able to reproduce it with 6.1.4 or 6.8.4. I can only guess this is what you were running into, so if this still seems to be happening, I'd recommend upgrading Elasticsearch (at least within a particular release branch) to see if that helps resolve the issue.
 

Dakis

Well-known member
@Mike I am having the same issue you described, I change word stemming from "none" to a specific language, save, xenforo says "your changes have been saved" but if I look at the option below it went back to "none". I tried rebuilding the index and it gives exact same results as before.

I am running ES 7.4.2 - could this be a bug?
 
Top