1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Duplicate Template Errors: PAGE_CONTAINER

Discussion in 'Resolved Bug Reports' started by silence, Jul 8, 2013.

  1. silence

    silence Well-Known Member

    Template Errors: PAGE_CONTAINER

    htmlspecialchars() expects parameter 1 to be string, array given in /xxx/xenforo/library/XenForo/Template/Helper/Core.php, line 2049

    This is happening on one of my users. He is using a mac and it happens globally on all styles including default.
    It is also happening on every browser.

    I'm using XenForo 1.2b4
     
  2. Jeremy

    Jeremy XenForo Moderator Staff Member

    Do you have any add-ons that deal with ignored users?
     
  3. silence

    silence Well-Known Member

    No I do not.
     
  4. Jeremy

    Jeremy XenForo Moderator Staff Member

    What is the user's name?
     
  5. silence

    silence Well-Known Member

    JayBreezy
     
  6. Jeremy

    Jeremy XenForo Moderator Staff Member

    Does this user have anybody on Ignore? If so, what are they're usernames? If you replicate his ignore list, does it happen for you?
     
  7. silence

    silence Well-Known Member

    uhhh how do I check a users ignored list?
     
  8. Jeremy

    Jeremy XenForo Moderator Staff Member

    You'll most likely have to ask the user, or look it up in the database.
     
  9. silence

    silence Well-Known Member

    He ignored one of my RSS bots.
    The name is
    ShackNewsBot
     
  10. Jeremy

    Jeremy XenForo Moderator Staff Member

    If you ignore that user, does it happen for you?
     
  11. silence

    silence Well-Known Member

    Strange, no it doesn't.
    But he unignored it and the errors stopped.
     
  12. Mike

    Mike XenForo Developer Staff Member

    If the user is seeing this, they're in debug mode - that's a bad thing, so you know. :)

    But this was caused by a bug in the user cache. rebuild system. Rebuilding users will fix it (as would adjusting your ignores).
     
    longanh likes this.
  13. silence

    silence Well-Known Member

    Is it bad in terms of resource usage or bad as in security risk?
     
  14. Mike

    Mike XenForo Developer Staff Member

    Potential for both.
     
  15. longanh

    longanh Member

    Yes , rebuid user cache will fix it :) (run for me)
     

Share This Page