• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.3 Template Errors: thread_view (Occurs when listeners disabled)

TeflonDon

Well-known member
#1
Template Errors: thread_view
  1. number_format() expects parameter 1 to be double, string given in /home/colicom/public_html/library/XenForo/Locale.php, line 720

Any ideas what could be causing this when I globally disable listeners?
 

Chris D

XenForo developer
Staff member
#2
Listeners will take care of various pieces of code that extend existing XenForo code. But it won't disable template modifications, naturally it won't disable manual template customisations either.

Disabling listeners basically isn't necessarily the same as disabling all add-ons.

First of all, as it's a template error, I'd be inclined to test it on a XenForo default style. If you no longer have this, you can create it by creating a new style with no parent.

That will narrow it down somewhat.

If the problem persists, I'd recommend disabling all add-ons manually.
 

TeflonDon

Well-known member
#3
Listeners will take care of various pieces of code that extend existing XenForo code. But it won't disable template modifications, naturally it won't disable manual template customisations either.

Disabling listeners basically isn't necessarily the same as disabling all add-ons.

First of all, as it's a template error, I'd be inclined to test it on a XenForo default style. If you no longer have this, you can create it by creating a new style with no parent.

That will narrow it down somewhat.

If the problem persists, I'd recommend disabling all add-ons manually.

Ahh, you're right its probably a template modification, forgot those would still be enabled in this situation. I'll try disabling listeners then disabling template mods for some of the addons that might be responsible.

Thanks