1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Some users saying site slow

Discussion in 'Troubleshooting and Problems' started by ibaker, May 1, 2012.

  1. ibaker

    ibaker Well-Known Member

    I have some users saying that my site http://www.aircraftpilots.com is running slow and not sure what I can do to assist them. My audience is predominately in Australia, the server (dedicated) is located on the US West Coast and the server has a lot of resources still available:
    Server load 0.11 (8 CPUs)
    Memory Used 12.16% (1,982,892 of 16,311,948)
    Swap Used 0% (0 of 2,097,144)

    It is only a few users and this is what they are saying:

    Can anyone give me ideas on what I can look into to help these users...thanks
  2. craigiri

    craigiri Well-Known Member

    I had a few such complaints - then took a poll, and it was only one or two users out of MANY.

    Most such situations are at the client (users) end and there is nothing you can do about them. In my case, they eventually fixed themselves for those users.
    0xym0r0n and Jake Bunce like this.
  3. Chris D

    Chris D XenForo Developer Staff Member

    Something important to note is, unfortunately, some older Firefox versions run incredibly poorly with XenForo.

    The users need to appreciate, though, that using old browsers is a choice they make, and although we can do everything we can to ensure current browsers work ok, verifying and supporting old browsers is impossible.

    One of our users was using Firefox 3.6. After upgrading, the site worked perfectly.

    Always get the full browser version.
  4. Chris D

    Chris D XenForo Developer Staff Member

    Yeah just to further ratify what I was saying, no mention of browser versions in that thread. They are essential for finding possible solutions to problems like this.
  5. mrGTB

    mrGTB Well-Known Member

    It does appear to be running slow, very noticeable when trying moving from one page to another, there a big delay.
  6. Chris D

    Chris D XenForo Developer Staff Member


    It's fine for me in Chrome.
  7. mrGTB

    mrGTB Well-Known Member

    Sorry, I'm downloading here in the background and forgot about it. Most likely slowing things down and didn't take that into consideration before.
  8. MattW

    MattW Well-Known Member

    It's fine for me as well on my iPad 2 using safari.
  9. p4guru

    p4guru Well-Known Member

    of course it's slow you have page size in 1MB range per page load http://tools.pingdom.com/fpt/#!/qLYNmzj0T/http://www.aircraftpilots.com/forum/

    and you haven't configured your server properly to leverage browser caching (i.e. mod_expires for apache)

    reduce page size to <250-450KB per page load + configure mod_expires properly for apache

    Still pages load fine for me from Australia but I'm on 100Mbps cable download speeds :)
  10. craigiri

    craigiri Well-Known Member

    P4, doesn't an initial page load spend a lot of time loading js and all the other stuff that then may not need reloading on other pages? If so, it's hard to use the example of a first page load.
  11. ibaker

    ibaker Well-Known Member

    This is great help guys...thanks for the leads!
  12. Digital Doctor

    Digital Doctor Well-Known Member

    Speed was good for me just now.
    Was surprised guests could not view "What's New in the last 24h".

  13. p4guru

    p4guru Well-Known Member

    even 2nd page load has no browser caching/expiration for some images if you run through webpagetest.org test i.e

    2nd page load http://www.webpagetest.org/result/120502_W8_9c35b014f7a3b139a0af708ba4ec8ea6/1/pagespeed/cached/

    same when using gtmetrix.com test no browser level caching http://gtmetrix.com/reports/www.aircraftpilots.com/56v3FajL

    use pagespeed results to measure by (yahoo yslow has a different definition for browser level caching/expires tags it seems)

    whole range of online tools and tests you can run are listed at http://vbtechsupport.com/388/
  14. DBA

    DBA Well-Known Member

    I hope that it isn't always that low usage, otherwise you're blowing a lot of money that you don't need to be. For you a server load of 8.0 would be 100% capacity.

    It doesn't appear that you're caching your static content. I'd suggest adding something like this to your root .htaccess file.

    <FilesMatch "\.(ico|pdf|flv|jpg|jpeg|png|gif|swf|mp3|mp4|css|js)$">
    Header set Cache-Control "max-age=2592000, public, must-revalidate"
  15. CyclingTribe

    CyclingTribe Well-Known Member

    Running nice and fast for me here in the UK. (y)
  16. Brentnauer

    Brentnauer Well-Known Member

    Try using CloudFlare; it will cache your static assets and distribute them from a CDN closest to your visitors. Might help.
    CyclingTribe likes this.
  17. Ingenious

    Ingenious Well-Known Member

    I'm interested to know what I can do on shared hosting to speed things up. I've tried turning off the Facebook, Twitter and G+ bits (as suggested by Brogan in another thread) and he's right, it does speed the page load up by quite a bit.

    I've read the XF docs about caching, but I assume these are for people with their own servers and won't be available to me on shared hosting?

    That sounds like a good idea, but would it have any other implications, say if I made changes to the forum (would people have to hard refresh pages to see the changes, for example, to graphics or the CSS?).

    In answer also to the OP, I had a couple of members reporting slow pages. It turned out I'd let images be uploaded at massive sizes, it only took a few of these in photo heavy threads to slow some browsers right down (even my Mac in some cases). So I put a max image dimension in at 1000px.

    I should add I am really pleased with the speed now - just being greedy and want more, especially after seeing Brogan's site run like s**t off a shovel on his new server!
  18. Brogan

    Brogan XenForo Moderator Staff Member

    You can use simple file caching on shared hosting.

    Create a directory named cache in internal_data and add this to your library/config.php file.

    $config['cache']['enabled'] = true;
    $config['cache']['cacheSessions'] = true;
    $config['cache']['backend'] = 'File';
    $config['cache']['backendOptions'] ['cache_dir'] = '/path/to/internal_data/cache';
    $config['cache']['frontend'] = 'Core';
    $config['cache']['frontendOptions'] ['cache_id_prefix'] = 'xf_';
    p4guru and Ingenious like this.
  19. mrGTB

    mrGTB Well-Known Member

    Do you need to use a prefix?
  20. Ingenious

    Ingenious Well-Known Member

    Thanks Brogan I'll give that a whirl tomorrow.

Share This Page