• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Single Sign On (Slave) by Waindigo [Deleted]

Jon W

Well-known member
#1
Waindigo submitted a new resource:

Single Sign On (Slave) by Waindigo - Allow your users to sign up once, then sign in across all your XenForo sites with that one login.

Description:
XenSSO is an addon for XenForo that at it’s core allows your users to sign up once, then sign in across all your XenForo sites with that one login. It uses OpenID under the hood and some custom tailoring for additional features not covered by OpenID.

Features of this add-on include:
  • Single Sign On, of course...
Read more about this resource...
 
Last edited:

Jon W

Well-known member
#4
Can pre-existing paid customers of XenSSO remove the copyright?
Only if you have a license that was purchased less than 12 months ago and have contacted me to transfer your license to Waindigo. All other users will have to buy a new license to remove copyright or to use on a commercial site.
 

faeronsayn

Well-known member
#5
@faeronsayn This looks like a bug with Widget Framework and nothing to do with this add-on at all.
Oops, sorry. Hmm, I've disabled the addon and I don't get any errors on the Master when I try to login on the slave, but I am getting this error on the slave.

Error Info
Exception: Waindigo_XenSso_Slave_ControllerPublic_Consumer::Waindigo_XenSso_Slave_ControllerPublic_Consumer::userRegister - createAccount - Errors on preSave: username: Usernames must be unique. The specified username is already in use. - library/XenForo/Error.php:202
Generated By: Unknown Account, A moment ago

Stack Trace
#0 /home2/asdf/public_html/community/library/Waindigo/XenSso/Slave/ControllerPublic/Consumer.php(195): XenForo_Error::debug('%s', 'Waindigo_XenSso...')
#1 /home2/asdf/public_html/community/library/Waindigo/XenSso/Slave/ControllerPublic/Consumer.php(118): Waindigo_XenSso_Slave_ControllerPublic_Consumer->userRegister(Object(Waindigo_XenSso_Slave_OpenId_Consumer), Object(Zend_OpenId_Extension_Sreg))
#2 /home2/asdf/public_html/community/library/Waindigo/XenSso/Slave/ControllerPublic/Consumer.php(91): Waindigo_XenSso_Slave_ControllerPublic_Consumer->userLogin(Object(Waindigo_XenSso_Slave_OpenId_Consumer), Object(Zend_OpenId_Extension_Sreg))
#3 /home2/asdf/public_html/community/library/XenForo/FrontController.php(337): Waindigo_XenSso_Slave_ControllerPublic_Consumer->actionCallback()
#4 /home2/asdf/public_html/community/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#5 /home2/asdf/public_html/community/index.php(13): XenForo_FrontController->run()
#6 {main}

Request State
array(3) {
["url"] => string(1590) "http://domain.com/community/sso-slave/callback?redirect=http://phanime.com/community/&username=Mangoes&errorType=requested_user_x_not_found&openid.assoc_handle=520b8ffb9526d&openid.return_to=http://phanime.com/community/sso-slave/callback?redirect=http%3A%2F%2Fdomain.com%2Fcommunity%2F&username=Mangoes&errorType=requested_user_x_not_found&openid.claimed_id=http://www.shadygamer.com/index.php?sso/Mangoes&openid.identity=http://www.domainMaster.com/index.php?sso/Mangoes&openid.response_nonce=2013-08-14T14:19:10Z520b91dec7512&openid.mode=id_res&openid.ns.sreg=http://openid.net/extensions/sreg/1.1&openid.sreg.nickname=Username&openid.sreg.email=asdf@gmail.com&openid.sreg.dob=14/4/1994&openid.signed=assoc_handle,return_to,claimed_id,identity,response_nonce,mode,ns.sreg,sreg.nickname,sreg.email,sreg.dob,signed&openid.sig=baQwIYC8xiM4wiq0rtUWLcSkarU=&authData=UCNXVZeuuXOwRk0a57sbNxK4aWoMVfb4mfOJqnF+aavfpnfrr3xwOx0E4by4QxLaOLVutDokqFiLXJc2rbJFRpL3VMJVjWtc6JHTLxykg0kY20Weu+Veh6DFocDXaBRqjAT0wHVFEhtHAUS35K50Zlhmfl9O5e706vTWyZOZ6oz22O3GSFYduHYR+ktAMpf4dgKkobs/8Q44PKIjMrdU0Dd2lnKYmoDHqHwcZGLGBlDDXMrOnb1umVnYgRqmKlkqMUc7kbBkRvL6aS0Att7ZlGmwrFize71oKgLB2DSe+B+/T3zQ63dVfufwcuunpZM+Xpa90anpxFrTnksnF7OWicCK4V3MQRgrDCBYquatQeDtuhrIpyBYiQhtqh1b1t9kEWZM9rAPVx2XfH8ZUP5ZdkfmwGe/dXYqLw7+sBdnyZRXdLSurbDiJ4/qIhyeNTHWWMspL/XzwEU/yx3MpXObo3C8/h2mU+YOAdEZkOf+I4+/gV0i5lxdEgyDLmPxicVd5j50mCb2mraP20zYEhSX07zedZpMn2Ls0ukogVaA9apiuAUGDOZU2L2CDiSm9yiQ"
["_GET"] => array(16) {
["redirect"] => string(29) "http://domain.com/community/"
["username"] => string(7) "Username"
["errorType"] => string(26) "requested_user_x_not_found"
["openid_assoc_handle"] => string(13) "520b8ffb9526d"
["openid_return_to"] => string(150) "http://domain.com/community/sso-slave/callback?redirect=http://domain.com/community/&username=Username&errorType=requested_user_x_not_found"
["openid_claimed_id"] => string(47) "http://www.domainMaster.com/index.php?sso/Username"
["openid_identity"] => string(47) "http://www.domainMaster.com/index.php?sso/Usernames"
["openid_response_nonce"] => string(33) "2013-08-14T14:19:10Z520b91dec7512"
["openid_mode"] => string(6) "id_res"
["openid_ns_sreg"] => string(37) "http://openid.net/extensions/sreg/1.1"
["openid_sreg_nickname"] => string(7) "Username"
["openid_sreg_email"] => string(16) "asdf@gmail.com"
["openid_sreg_dob"] => string(9) "14/4/1994"
["openid_signed"] => string(111) "assoc_handle,return_to,claimed_id,identity,response_nonce,mode,ns.sreg,sreg.nickname,sreg.email,sreg.dob,signed"
["openid_sig"] => string(28) "baQwIYC8xiM4wiq0rtUWLcSkarU="
["authData"] => string(576) "UCNXVZeuuXOwRk0a57sbNxK4aWoMVfb4mfOJqnF+aavfpnfrr3xwOx0E4by4QxLaOLVutDokqFiLXJc2rbJFRpL3VMJVjWtc6JHTLxykg0kY20Weu+Veh6DFocDXaBRqjAT0wHVFEhtHAUS35K50Zlhmfl9O5e706vTWyZOZ6oz22O3GSFYduHYR+ktAMpf4dgKkobs/8Q44PKIjMrdU0Dd2lnKYmoDHqHwcZGLGBlDDXMrOnb1umVnYgRqmKlkqMUc7kbBkRvL6aS0Att7ZlGmwrFize71oKgLB2DSe+B+/T3zQ63dVfufwcuunpZM+Xpa90anpxFrTnksnF7OWicCK4V3MQRgrDCBYquatQeDtuhrIpyBYiQhtqh1b1t9kEWZM9rAPVx2XfH8ZUP5ZdkfmwGe/dXYqLw7+sBdnyZRXdLSurbDiJ4/qIhyeNTHWWMspL/XzwEU/yx3MpXObo3C8/h2mU+YOAdEZkOf+I4+/gV0i5lxdEgyDLmPxicVd5j50mCb2mraP20zYEhSX07zedZpMn2Ls0ukogVaA9apiuAUGDOZU2L2CDiSm9yiQ"
}
["_POST"] => array(0) {
}
}


By the way this user does exist on the Master installation.
 

Jon W

Well-known member
#6
@faeronsayn So this looks like an error that you get when you are synchronising your slave with the master. Is that correct?

It sounds like you have a user on your slave server that already exists on your master server. This is not allowed, so you will need to rename this user on the slave server if you want to sync it with the master. Or you can just ignore the error.
 

faeronsayn

Well-known member
#7
@faeronsayn So this looks like an error that you get when you are synchronising your slave with the master. Is that correct?

It sounds like you have a user on your slave server that already exists on your master server. This is not allowed, so you will need to rename this user on the slave server if you want to sync it with the master. Or you can just ignore the error.
No, this is happening when I am trying to login on the slave with an account that is on the master. On the front end, I get this error,

Single Sign On could not complete as your profile could not be validated, possibly your username is already taken, a duplicate was found or you do not meet the age requirements.

On the back end, I get the error that I posted. I have Require Date of Birth and Minimum Age enabled and set to 13 on both sites.
 

Jon W

Well-known member
#8
No, this is happening when I am trying to login on the slave with an account that is on the master. On the front end, I get this error,

Single Sign On could not complete as your profile could not be validated, possibly your username is already taken, a duplicate was found or you do not meet the age requirements.

On the back end, I get the error that I posted. I have Require Date of Birth and Minimum Age enabled and set to 13 on both sites.
If the errors are related (they might not be), then you need to rename the account and re-sync with the master as it is saying that there is a clash of usernames.

Also, could you please post error messages relating to the Slave Server in the appropriate thread.
 
Last edited:

faeronsayn

Well-known member
#9
If the errors are related (they might not be), then you need to rename the account and re-sync with the master as it is saying that there is a clash of usernames.

Also, could you please post error messages relating to the Slave Server in the appropriate thread.
Sorry, about that.

I think you are misunderstanding me.

There is no user named "UsernameA" in the slave installation.

However, there is a user named "UsernameA" in the master installation.

When I try to login with "UsernameA" on the slave installation, I get the above error. However, user with "UsernameA" does not exist on the slave installation. I've double checked.
 

Jon W

Well-known member
#11
Have you replaced any of the domain names before posting the error you posted above? Or have you not actually put your own domain name in the options for this add-on?
 

faeronsayn

Well-known member
#12
Have you replaced any of the domain names before posting the error you posted above? Or have you not actually put your own domain name in the options for this add-on?

I've setup my domain names before I did this. The error came after that.

If my forum is on /community

should the allowed domain name be: mydomain.com/community ?

Currently, I've set it up as : mydomain.com
 

Jon W

Well-known member
#15
No, I censored my own domain names, I changed them to those to show the error.
Ok. Seems you only censored about half of it, which was quite confusing.

I've setup my domain names before I did this. The error came after that.

If my forum is on /community

should the allowed domain name be: mydomain.com/community ?

Currently, I've set it up as : mydomain.com
Yes, you need to put /community on your slave server.
 

Jon W

Well-known member
#16
Where would I put /community on my slave server?

If you're talking about putting mydomainSlave.com/community on my allowed domains on the master installation, I've done that. The error persists.
Wrong way round.

In the options on your slave server you need to put the URL of your master server (e.g., http://mydomain.com/community/).

On the master server, you only need to put the domain names in (e.g., mydomain.com).
 

Jon W

Well-known member
#18
Already have my master server's URL and I've changed the slave server's to domain name now. Essentially, all the settings are fine. The error still is popping up.
I'm unable to replicate this. Please check all your server settings again and make sure that the user you are trying to log in as has their date of birth set on the master and that they are older than the required age.
 

faeronsayn

Well-known member
#19
I'm unable to replicate this. Please check all your server settings again and make sure that the user you are trying to log in as has their date of birth set on the master and that they are older than the required age.
if they are registered through facebook, could that be a problem?

However, I've tried two different users, who have date of births set and have an age greater than 13. I'm not exactly sure what's wrong, this addon (provided by Nathan) was working on v1.1. Then I updated the add-on because of 1.2 and now I'm getting a few issues that I can't seem to solve.

Is there anyway we can narrow down the issue / isolate the cause of the problem? Since you cannot replicate it, it must be something with the settings. I doubt the server configuration is the problem since this addon was running previously without much issue.