1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Single Sign On (Slave) by Waindigo [Deleted]

Discussion in 'Add-on Releases' started by Jon W, Aug 12, 2013.

  1. Jon W

    Jon W Well-Known Member

    Waindigo submitted a new resource:

    Single Sign On (Slave) by Waindigo - Allow your users to sign up once, then sign in across all your XenForo sites with that one login.

    Read more about this resource...
     
    Last edited: Aug 12, 2013
    Lê Văn Hoành likes this.
  2. cmeinck

    cmeinck Well-Known Member

    Can pre-existing paid customers of XenSSO remove the copyright?
     
  3. Kainzo

    Kainzo Active Member

    Jon W likes this.
  4. Jon W

    Jon W Well-Known Member

    Only if you have a license that was purchased less than 12 months ago and have contacted me to transfer your license to Waindigo. All other users will have to buy a new license to remove copyright or to use on a commercial site.
     
  5. faeronsayn

    faeronsayn Well-Known Member

    Oops, sorry. Hmm, I've disabled the addon and I don't get any errors on the Master when I try to login on the slave, but I am getting this error on the slave.

    Error Info
    Exception: Waindigo_XenSso_Slave_ControllerPublic_Consumer::Waindigo_XenSso_Slave_ControllerPublic_Consumer::userRegister - createAccount - Errors on preSave: username: Usernames must be unique. The specified username is already in use. - library/XenForo/Error.php:202
    Generated By: Unknown Account, A moment ago

    Stack Trace
    #0 /home2/asdf/public_html/community/library/Waindigo/XenSso/Slave/ControllerPublic/Consumer.php(195): XenForo_Error::debug('%s', 'Waindigo_XenSso...')
    #1 /home2/asdf/public_html/community/library/Waindigo/XenSso/Slave/ControllerPublic/Consumer.php(118): Waindigo_XenSso_Slave_ControllerPublic_Consumer->userRegister(Object(Waindigo_XenSso_Slave_OpenId_Consumer), Object(Zend_OpenId_Extension_Sreg))
    #2 /home2/asdf/public_html/community/library/Waindigo/XenSso/Slave/ControllerPublic/Consumer.php(91): Waindigo_XenSso_Slave_ControllerPublic_Consumer->userLogin(Object(Waindigo_XenSso_Slave_OpenId_Consumer), Object(Zend_OpenId_Extension_Sreg))
    #3 /home2/asdf/public_html/community/library/XenForo/FrontController.php(337): Waindigo_XenSso_Slave_ControllerPublic_Consumer->actionCallback()
    #4 /home2/asdf/public_html/community/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
    #5 /home2/asdf/public_html/community/index.php(13): XenForo_FrontController->run()
    #6 {main}

    Request State
    array(3) {
    ["url"] => string(1590) "http://domain.com/community/sso-slave/callback?redirect=http://phanime.com/community/&username=Mangoes&errorType=requested_user_x_not_found&openid.assoc_handle=520b8ffb9526d&openid.return_to=http://phanime.com/community/sso-slave/callback?redirect=http%3A%2F%2Fdomain.com%2Fcommunity%2F&username=Mangoes&errorType=requested_user_x_not_found&openid.claimed_id=http://www.shadygamer.com/index.php?sso/Mangoes&openid.identity=http://www.domainMaster.com/index.php?sso/Mangoes&openid.response_nonce=2013-08-14T14:19:10Z520b91dec7512&openid.mode=id_res&openid.ns.sreg=http://openid.net/extensions/sreg/1.1&openid.sreg.nickname=Username&openid.sreg.email=asdf@gmail.com&openid.sreg.dob=14/4/1994&openid.signed=assoc_handle,return_to,claimed_id,identity,response_nonce,mode,ns.sreg,sreg.nickname,sreg.email,sreg.dob,signed&openid.sig=baQwIYC8xiM4wiq0rtUWLcSkarU=&authData=UCNXVZeuuXOwRk0a57sbNxK4aWoMVfb4mfOJqnF+aavfpnfrr3xwOx0E4by4QxLaOLVutDokqFiLXJc2rbJFRpL3VMJVjWtc6JHTLxykg0kY20Weu+Veh6DFocDXaBRqjAT0wHVFEhtHAUS35K50Zlhmfl9O5e706vTWyZOZ6oz22O3GSFYduHYR+ktAMpf4dgKkobs/8Q44PKIjMrdU0Dd2lnKYmoDHqHwcZGLGBlDDXMrOnb1umVnYgRqmKlkqMUc7kbBkRvL6aS0Att7ZlGmwrFize71oKgLB2DSe+B+/T3zQ63dVfufwcuunpZM+Xpa90anpxFrTnksnF7OWicCK4V3MQRgrDCBYquatQeDtuhrIpyBYiQhtqh1b1t9kEWZM9rAPVx2XfH8ZUP5ZdkfmwGe/dXYqLw7+sBdnyZRXdLSurbDiJ4/qIhyeNTHWWMspL/XzwEU/yx3MpXObo3C8/h2mU+YOAdEZkOf+I4+/gV0i5lxdEgyDLmPxicVd5j50mCb2mraP20zYEhSX07zedZpMn2Ls0ukogVaA9apiuAUGDOZU2L2CDiSm9yiQ"
    ["_GET"] => array(16) {
    ["redirect"] => string(29) "http://domain.com/community/"
    ["username"] => string(7) "Username"
    ["errorType"] => string(26) "requested_user_x_not_found"
    ["openid_assoc_handle"] => string(13) "520b8ffb9526d"
    ["openid_return_to"] => string(150) "http://domain.com/community/sso-slave/callback?redirect=http://domain.com/community/&username=Username&errorType=requested_user_x_not_found"
    ["openid_claimed_id"] => string(47) "http://www.domainMaster.com/index.php?sso/Username"
    ["openid_identity"] => string(47) "http://www.domainMaster.com/index.php?sso/Usernames"
    ["openid_response_nonce"] => string(33) "2013-08-14T14:19:10Z520b91dec7512"
    ["openid_mode"] => string(6) "id_res"
    ["openid_ns_sreg"] => string(37) "http://openid.net/extensions/sreg/1.1"
    ["openid_sreg_nickname"] => string(7) "Username"
    ["openid_sreg_email"] => string(16) "asdf@gmail.com"
    ["openid_sreg_dob"] => string(9) "14/4/1994"
    ["openid_signed"] => string(111) "assoc_handle,return_to,claimed_id,identity,response_nonce,mode,ns.sreg,sreg.nickname,sreg.email,sreg.dob,signed"
    ["openid_sig"] => string(28) "baQwIYC8xiM4wiq0rtUWLcSkarU="
    ["authData"] => string(576) "UCNXVZeuuXOwRk0a57sbNxK4aWoMVfb4mfOJqnF+aavfpnfrr3xwOx0E4by4QxLaOLVutDokqFiLXJc2rbJFRpL3VMJVjWtc6JHTLxykg0kY20Weu+Veh6DFocDXaBRqjAT0wHVFEhtHAUS35K50Zlhmfl9O5e706vTWyZOZ6oz22O3GSFYduHYR+ktAMpf4dgKkobs/8Q44PKIjMrdU0Dd2lnKYmoDHqHwcZGLGBlDDXMrOnb1umVnYgRqmKlkqMUc7kbBkRvL6aS0Att7ZlGmwrFize71oKgLB2DSe+B+/T3zQ63dVfufwcuunpZM+Xpa90anpxFrTnksnF7OWicCK4V3MQRgrDCBYquatQeDtuhrIpyBYiQhtqh1b1t9kEWZM9rAPVx2XfH8ZUP5ZdkfmwGe/dXYqLw7+sBdnyZRXdLSurbDiJ4/qIhyeNTHWWMspL/XzwEU/yx3MpXObo3C8/h2mU+YOAdEZkOf+I4+/gV0i5lxdEgyDLmPxicVd5j50mCb2mraP20zYEhSX07zedZpMn2Ls0ukogVaA9apiuAUGDOZU2L2CDiSm9yiQ"
    }
    ["_POST"] => array(0) {
    }
    }


    By the way this user does exist on the Master installation.
     
  6. Jon W

    Jon W Well-Known Member

    @faeronsayn So this looks like an error that you get when you are synchronising your slave with the master. Is that correct?

    It sounds like you have a user on your slave server that already exists on your master server. This is not allowed, so you will need to rename this user on the slave server if you want to sync it with the master. Or you can just ignore the error.
     
  7. faeronsayn

    faeronsayn Well-Known Member

    No, this is happening when I am trying to login on the slave with an account that is on the master. On the front end, I get this error,

    Single Sign On could not complete as your profile could not be validated, possibly your username is already taken, a duplicate was found or you do not meet the age requirements.

    On the back end, I get the error that I posted. I have Require Date of Birth and Minimum Age enabled and set to 13 on both sites.
     
  8. Jon W

    Jon W Well-Known Member

    If the errors are related (they might not be), then you need to rename the account and re-sync with the master as it is saying that there is a clash of usernames.

    Also, could you please post error messages relating to the Slave Server in the appropriate thread.
     
    Last edited: Aug 14, 2013
  9. faeronsayn

    faeronsayn Well-Known Member

    Sorry, about that.

    I think you are misunderstanding me.

    There is no user named "UsernameA" in the slave installation.

    However, there is a user named "UsernameA" in the master installation.

    When I try to login with "UsernameA" on the slave installation, I get the above error. However, user with "UsernameA" does not exist on the slave installation. I've double checked.
     
  10. faeronsayn

    faeronsayn Well-Known Member

    I have just tried with another user on the master installation that does not exist on the slave installation, same error.
     
  11. Jon W

    Jon W Well-Known Member

    Have you replaced any of the domain names before posting the error you posted above? Or have you not actually put your own domain name in the options for this add-on?
     
  12. faeronsayn

    faeronsayn Well-Known Member


    I've setup my domain names before I did this. The error came after that.

    If my forum is on /community

    should the allowed domain name be: mydomain.com/community ?

    Currently, I've set it up as : mydomain.com
     
  13. Jon W

    Jon W Well-Known Member

    Your error message shows the domains domain.com and domainmaster.com. Do you actually own these domains?
     
  14. faeronsayn

    faeronsayn Well-Known Member

    No, I censored my own domain names, I changed them to those to show the error.
     
  15. Jon W

    Jon W Well-Known Member

    Ok. Seems you only censored about half of it, which was quite confusing.

    Yes, you need to put /community on your slave server.
     
  16. Jon W

    Jon W Well-Known Member

    Wrong way round.

    In the options on your slave server you need to put the URL of your master server (e.g., http://mydomain.com/community/).

    On the master server, you only need to put the domain names in (e.g., mydomain.com).
     
  17. faeronsayn

    faeronsayn Well-Known Member

    Already have my master server's URL and I've changed the slave server's to domain name now. Essentially, all the settings are fine. The error still is popping up.
     
  18. Jon W

    Jon W Well-Known Member

    I'm unable to replicate this. Please check all your server settings again and make sure that the user you are trying to log in as has their date of birth set on the master and that they are older than the required age.
     
  19. faeronsayn

    faeronsayn Well-Known Member

    if they are registered through facebook, could that be a problem?

    However, I've tried two different users, who have date of births set and have an age greater than 13. I'm not exactly sure what's wrong, this addon (provided by Nathan) was working on v1.1. Then I updated the add-on because of 1.2 and now I'm getting a few issues that I can't seem to solve.

    Is there anyway we can narrow down the issue / isolate the cause of the problem? Since you cannot replicate it, it must be something with the settings. I doubt the server configuration is the problem since this addon was running previously without much issue.
     
  20. Jon W

    Jon W Well-Known Member

Share This Page