1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

As Designed Reopen - "Log Out" logs me out of Facebook

Discussion in 'Resolved Bug Reports' started by tia, Oct 3, 2014.

  1. tia

    tia Member

    RoldanLT and imthebest like this.
  2. Mike

    Mike XenForo Developer Staff Member

  3. tia

    tia Member

    The point is that it is not in the Platform Policy anymore, so Xenforo forum administrator as a Facebook developer do not have obligation to force logging user out of the Facebook at all even it is still "recommended" or "best practice." At least please consider making it a system option and let us decide.
    RoldanLT likes this.
  4. Chris D

    Chris D XenForo Developer Staff Member

    XenForo, quite rightly, will always adhere to recommended and best practice when dealing with external APIs. Why would they go against recommendations?

    It seems like you will have to look at having some custom code developed if you would like to change the behaviour.
  5. tia

    tia Member

    Because we are serving our users, not Facebook. The practice is not technical recommendation or best practice, Facebook stated it clearly that they want the behaviour to be "as users expected", which in the reality is actually the other way round. Of course I have no other choice but fix it by myself if XenForo chose to keep it like that, I will just be disappointed. :(
  6. xfrocks

    xfrocks Well-Known Member

    If XenForo doesn't log you out of Facebook when you log out of the forums, after the logout redirect you will be logged in again immediately because the script detects the Facebook session and trigger the XenForo login routine.
    Chris D likes this.

Share This Page