1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 Can't log out of my forum after trying to reset Facebook integration

Discussion in 'Troubleshooting and Problems' started by sitwi, May 13, 2014.

  1. sitwi

    sitwi Active Member

    I've installed 1.3.2 (don't know whether that's related?) and had all manner of problems this evening after trying to sort my Facebook integration, when it appeared to crash partway through.

    First, it kept logging me off of Facebook, which I've never heard of.

    While I was logged out of Facebook, it kept refreshing my forum homepage on its own - again, never seen this.

    If I click the admin link up top, it takes me back to the login screen, although it acknowledges I'm already logged into my account, and it point blank refuses to accept my password.

    And now I'm unable to log out of my account. Whichever way I try it, it just redirects to my forum front page.

    Completely baffled at all of this. Does anyone have any ideas please? I've tried different themes, and the standard default them, with the same result. If for some reason I'm booted out of this one admin window I have open, that'll be it - I won't be able to get back in.
  2. Liam W

    Liam W Well-Known Member

    Are there any server errors in the log?

    Do the errors remain if you disable all addons?
  3. sitwi

    sitwi Active Member

    I'd have answered that, but the admin window has booted me out, and I can't get back in. I don't suppose this is a known issue...? I'm completely locked out of my site. Can't log into Admin, and can't log out of my account!
  4. Liam W

    Liam W Well-Known Member

    I'm assuming you have FTP access?

    Add this to the config.php file (library/config.php):

    $config['enableListeners'] = false;
    That'll disable all addons. You should (hopefully) be able to login then.

  5. sitwi

    sitwi Active Member

    Thanks. That's let me in - and the server error log is empty.

    I'll start again from scratch on this if I have to - soul destroying as I've been working solid 12 hour days on this for the last two weeks, and we were just about ready to go live.

    Absolutely puzzled what has caused this - it seems to be when I was messing with the Facebook integration. I've since closed my FB app down.
  6. Liam W

    Liam W Well-Known Member

    If that let you in, then its an add on doing it.

    Do you have any Facebook related addons?
  7. sitwi

    sitwi Active Member

    I did have one FB-related plugin - [bd] Social Share - but it's disabled. As are all my add-ons now... but it's still not letting me log out of my account. I've rebuilt the master data, if that's any use.
  8. sitwi

    sitwi Active Member

    This is F'd. I've tried a vanilla installation with no addons, different database and no styles, all reimported from my old VB board... and I still can't log in. I had to ask for a password reset, and when I try the new one it says "This action is available via POST only. Please press the back button and try again."

    Have I really just lost all my work?
  9. Amaury

    Amaury Well-Known Member

    You could try submitting a ticket to XenForo. They'd be more than happy to help.
    sitwi likes this.
  10. Tracy Perry

    Tracy Perry Well-Known Member

    Have you tried it with a different browser. I just ran into something similar while using Chrome on my Mac (was updating one of the forums to 1.3.2 and it would never detect that the upgrade was in place). Ended up having to log in via Safari to perform the upgrade.

Share This Page