• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Not a bug PM not working right?

#1
Hi, when I was on one of my test websites, I remembered that I had disabled private messaging. ( I did it by doing this: ACP >Options> User Registration> Initiate Conversation With This User> Nobody), and today, I tried to turn it back on ( ACP >Options> User Registration> Initiate Conversation With This User> Members Only). But then when I refreshed the page the 'start a conversation' button still didn't show up!

So then, I went on another test website of ours, which, I know private conversations are allowed and just to be sure I double checked that in my profile page, the 'start a conversation' button was there. But when I turned it off(through ACP >Options> User Registration> Initiate Conversation With This User> Nobody), and then refreshed my pages, the 'start a conversation' button was still there! It was really weird.

Could someone tell me how to resolve this problem? Is this a bug? Thanks a lot!
 
#3
I see. So if we set user registration default as Initiate Conversation With This User>Nobody, then AFTER user registered on our site, how do we change that to allow the existing users Initiate Conversation with other members only?