User Promotion Not Working

Steve Freides

Active member
I am trying to debug, I'd guess you'd say, a new User Promotion. Details are quite simple.

1. We already run a user promotion that was recommended when we started with XF called Promoted Member that adds people to a group called Verified once they've posted 3 times.

2. I have a group called Instructors. I want all Instructors to be members of Verified irrespective of how many times they've posted, so I created a new User promotion. It say to add you to the group Verified if you're in the group Instructors and you're not in the group Verified. I still 512 people who my search finds when I look for exactly this, member of Instructors and not a member of Verified. When I search within User Promotions, I find exactly one person who has been promoted - why not all of them? I had 513 yesterday

The Promotion is Active. The group Verified is checked on the first page.
Is a member of Instructors, is not a member of Verified is on my second page.
User Field Criteria is untouched and empty.

I took the liberty of going into Cron both yesterday and today and telling it to run User Group Promotions - that seems to do nothing.

I'd appreciate any suggestions as to where to look or what to do next.

Thanks in advance for your replies.

-S-
 

Brogan

XenForo moderator
Staff member
Check the user change log for one of the members - it will likely indicate they have been promoted and demoted.

That suggests conflicting criteria.

so I created a new User promotion. It say to add you to the group Verified if you're in the group Instructors and you're not in the group Verified.
I would remove the second part and just do a simple promotion to Verified if in Instructors.
 

Steve Freides

Active member
Check the user change log for one of the members - it will likely indicate they have been promoted and demoted.

This is not the case - I checked two random people out of my 512.

I would remove the second part and just do a simple promotion to Verified if in Instructors.
The reason I didn't do it that way was I didn't want it to try to do something that had already been done for each of these people.

I don't believe what I've asked for suggests conflicting data - seems reasonable to say, "if they're in group 1 and not in group 2, add them to group 2."

I'm happy to try it as you suggested, but I'm also interested in understanding why what I haven't gotten the expected result.

-S-
 

Brogan

XenForo moderator
Staff member
he reason I didn't do it that way was I didn't want it to try to do something that had already been done for each of these people.
It doesn't matter.

Members who have already been promoted won't be affected.

If the criteria is correct, the only reason members wouldn't be promoted is due to them not being active for a while.
Run the rebuild usergroup promotions task in the tools menu, NOT the cron task.
 

Steve Freides

Active member
Alright, some progress, still not quite right.

I actually have two new user group promotions, one as described, and another for a second group, called Instructors Elite. For some reason, the first one works - good - but the second one doesn't.

Your suggestion to Tools, Rebuild Caches, Rebuild User Caches - I did get that right, didn't I? - seems to have made the one work but not the other.

-S-
 

Steve Freides

Active member
If you don't mind, a related question:

I created two user group promotions because of the criteria, one for Instructors and another for Elite Instructors. I see now that I could have selected both group in the "is a member of any of the selected groups" and accomplished the same thing with just a single user group promotion Do I understand that correctly?

-S-
 
Last edited:
Top