XF 2.0 PayPal Instant Payment Notification Warning

PumpinIron

Well-known member
@AddonFlare let me know there was a setting in my PayPal that wasn't enabled called "payment data transfer".

I enabled it, so I wonder if this will make any difference going forward.
 

tourmeister

Active member
Did you ever get this resolved.

I have had PayPal working great on my site for some time, and now I just got an email exactly like yours.

I went to PayPal and found this,

195226

I don't recall EVER going to this page before and changing anything or entering a URL (which is not to say I didn't but I may have just forgotten since then...).
 

PumpinIron

Well-known member
Did you ever get this resolved.

I have had PayPal working great on my site for some time, and now I just got an email exactly like yours.

I went to PayPal and found this,

View attachment 195226

I don't recall EVER going to this page before and changing anything or entering a URL (which is not to say I didn't but I may have just forgotten since then...).
I never managed to actually figure out why it was happening other than what's mentioned in the previous posts in this thread.

The odd thing is that it still happens every so often (maybe once every 2 months), but only on maybe 1 out of every 100 transactions. I just gave up on trying to figure it out as it happens so seldom that I'm not really sure what it could be.

I haven't had any issues since posting this thread for what it's worth.
 

Ranger375

Well-known member
This happens to me as well every few months abd I basically have to go in and keep it enabled. Weird though because the address has stayed the same...
 

tourmeister

Active member
So I updated this.

195268

I have received several successful payments since and the account upgrades on XF worked as they should.

I did have to go back through about a week of payments that were successful, but where the upgrade on XF did not work, and do manual upgrades.
 

PumpinIron

Well-known member
This happens to me as well every few months abd I basically have to go in and keep it enabled. Weird though because the address has stayed the same...
Yep, same with mine.

This is something I honestly can't explain, but it seems to work more or less, so I'm not complaining.
 

cdub

Well-known member
Got this error as well from PayPal for the first time. Looking into it now. I'm getting no errors in my sites payment log.
 

cdub

Well-known member
Hmm.... Maybe it's because it's for the paid registration add-on and it results in the 503 error if they haven't verified their email address yet for the new registration.

It's always on a new registration when I get the error but not everytime.
 

cdub

Well-known member
Yes the error is definitely because the user hasn't confirmed their email address yet. It's because PayPal is trying to ping back the user but the user hasn't been created yet.
 

cdub

Well-known member
Went to the PayPal IPN log right after I received payment with registration and error was there. After the user was confirmed the error went away.
 
Top