• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

RM 1.1 Outdated templates after installing RM 1.1

The Sandman

Well-known member
#1
After installing RM 1.1 Beta 2 I'm getting notification of 5 outdated templates in my Soft Responsive style -
file_uploader.css, resource_list.css, resource_update.css, resource_view.css, and resource_view_header.css. I did not have any outdated templates before the install. If I try to merge the changes, I get a message telling me that no previous version of the parent could be found, and that merging is not possible.

I mentioned this to the style developer Arty, who thinks it's a bug in XenForo:
When you install add-on or update XenForo it sets last modification time for those templates to time of add-on installation / XF upgrade. Template in style was edited a while ago so it has lower last modification time and XF thinks its outdated.
What should I do about the 5 "outdated" templates?
 

Mike

XenForo developer
Staff member
#2
His explanation is correct and exactly how it works. I'm not sure what he's saying is wrong there as if you edited the child style before the parent style was edited, that's sort of the very definition of an outdated template.

However, someone else had something like this with an add-on but it's not something I've ever been able to reproduce.

If you're still having the issue, can you provide a dump of a few tables? xf_template and xf_template_history should be sufficient.
 

Mike

XenForo developer
Staff member
#4
Well, you may want to update them, but it'd have to be done manually (either with the standard revert/redo method or using the simple 2-way comparison system to figure out what the changes are and whether they need to be applied). The merging issue may not be resolveable retroactively.

(I have grabbed the data that you sent, thanks.)
 

Mike

XenForo developer
Staff member
#5
Wait, I just realized a few things - I assumed you were upgrading the RM, rather than doing a fresh install. This also seems consistent with the data that you had. You simply had the style installed (that modified RM components) before you had the RM installed itself.

So yeah, I can see where this is potentially misleading, but I'd rather list something as out of date than not if we're not sure. Since the master template was updated more recently than the customized version, we don't know for a fact that it's not outdated. (We don't only look at version comparisons but actual edit date comparisons.)

If it's a false positive, you should be able to resolve it by simply saving the template again.
 

The Sandman

Well-known member
#6
I *think* I understand. And fortuitously for me I have @Arty to help me, who advised me to save the templates without making any changes a little while ago. No more outdated templates! Thanks Mike and Arty! :)