1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can't Fix Odd thing spotted with LIKES given to another member.

Discussion in 'Resolved Bug Reports' started by mrGTB, Nov 14, 2011.

  1. mrGTB

    mrGTB Well-Known Member

    So I deleted a member on my forum who made a LIKE on a post beforehand. Today another member joined my forum and has not posted anything since. The odd thing though, that LIKE the other member made (now deleted from the forum) is still showing in a post, but if you click that LIKE it leads to the member that's joined today who never posted that LIKE.

    View this page and the LIKE made by Kris. It shows it has being made by "Sandeep" who never made that like. Also, why is that LIKE still there when the member that made it as been deleted from the forum completely, there are not even any forum posts left behind listed from that deleted member?

    Also, that member Sandeep is not showing up in the members list because he's listed as still awaiting email confirmation.

    Link: http://mrgtb.com/threads/new-horror-forum-but-i-dont-like-red-colour.797/
     
  2. Alluidh

    Alluidh Well-Known Member

    Strange that both members got the ID 8. kris.8 and sandeep.8.
     
  3. mrGTB

    mrGTB Well-Known Member

    No, I did NOT rename any member to another name. Neither have I been into the database itself to manually clean away old members listed for it to have possibly took the same ID that way too.
     
  4. Alluidh

    Alluidh Well-Known Member

    And both members are deleted? I only found 4 members, (ID 1, 3, 4 and 7)

    The was a bug with likes and deleted members some days ago - I'll try to find ....
     
  5. mrGTB

    mrGTB Well-Known Member

    No, the member called Sandeep is listed as still awaiting email activation. He/She don't show as active under Users in the Admin CP and why they don't show also in the members list. Yet, I just looked at users in the database itself and Sandeep is listed as ID.8

    But Sandeep is listed after GTB (ID7) I created for testing things weeks ago as a regular member account. There has been other members since GTB before Sandeep joined. So really that should I would have thought had a few number skips from Id7 to Sandeep who should have been listed around ID10 or 11.

    I've even just thought have I maybe restored an old database backup before those members was deleted. I've not and even if I had that LIKE would not be there.

    Snap1.png
     
  6. mrGTB

    mrGTB Well-Known Member

  7. mrGTB

    mrGTB Well-Known Member

    I'll give you time to look at this, then later I'm manually removing all LIKES from the database itself and deleting that obvious spam member who joined called Sandeep.
     
  8. erich37

    erich37 Well-Known Member

    there was a similar bug reported in the past.
    can not find it now...
     
  9. mrGTB

    mrGTB Well-Known Member

    Well in that case then they're aware of this issue already so I'll go ahead and delete all this to fix thing on my forum.
     
  10. erich37

    erich37 Well-Known Member

    better do not change anything on your forum, but let Mike first check the issue on your forum.
    this issue is probably hard to reproduce, and easier to fix if Mike or Kier can check where the issue is coming from by looking onto your forum.
     
  11. mrGTB

    mrGTB Well-Known Member

    Well, sorry too late I'd already gone into the database and removed all the likes listed in the field called "xf_liked_content". But the like is still shown in that thread still. Now I've just liked that same post on purpose and it changed saying (deleted user) instead for that other member deleted with no link leading back a profile anymore.

    Thing is though, if I've deleted all likes from that database field (I can't see another used for showing them)? Why have they not also been removed from the forum?
     
  12. Jeremy P

    Jeremy P Well-Known Member

    IIRC likes are not deleted with users. Their name will remain in the list of users who liked the post, that is intentional.

    What went wrong here is a member somehow was assigned the deleted user's id.

    The only thing besides manual manipulation that I can think would cause this is I believe hearing that if mysql is restarted after the latest inserted row in a table is removed, the auto increment value may have rolled back one.
     
  13. Jeremy

    Jeremy XenForo Moderator Staff Member

    I remember the bug in question and remember this being a System bug related to mySQL. If I remember correctly, the way mySQL handles auto-incremented tables is to keep track of the last given ID and increase it by one. If the mySQL server is restarted or something else happens to it (the actual server, NOT the db), it clears the previously given ID (so "9") and does last found ID and increments it by one. so 7+1 = 8. And since the cache and everything stores it related by ID and NOT username, so when the new user registered, mySQL assignes them ID 8, which XenForo starts reading from.
     
    Mike likes this.
  14. mrGTB

    mrGTB Well-Known Member

    Well you might have something in that, because my site could not be accessed for a short while yesterday, even cPanel could not be gained accessed too. So maybe they did restart mySQL for some odd reason that's caused this.
     
  15. Jeremy

    Jeremy XenForo Moderator Staff Member

  16. mrGTB

    mrGTB Well-Known Member

    No problem, I've removed one post that had a like in it linking to an error page, the other has changed to read deleted member with no link attached to it at all. Just as well there wasn't 500 likes to go running around fixing really.
     

Share This Page