1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 need to relog in repeatedly as you move between sections

Discussion in 'Troubleshooting and Problems' started by florencia, Mar 23, 2014.

  1. florencia

    florencia Active Member

    Log in seems problematic -- you need to relog in repeatedly as you move between sections. what can be causing this problem?
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Switching between www and non-www is the most common culprit.
    It also happens when switching between http and https.
     
  3. florencia

    florencia Active Member

    I checked and the URL of the different sections is always the same, it doesn't changes from www to non-wwww or between http and https? sections are nameofforum.com/about, nameofforum.com/resources, nameofforum.com/forum, etc. any other ideas? It is not happening to me, its happens to a user of the forum.
     
  4. Tracy Perry

    Tracy Perry Well-Known Member

    I assume then you have a re-write in place that forces all www. to non-www format (or vice-versa)?
     
  5. florencia

    florencia Active Member

    in place where? mmhh
     
  6. Tracy Perry

    Tracy Perry Well-Known Member

    depends on what http server you are using. Apache2 then in .htaccess, nginx in the vhost config, OpenLiteSpeed in the Vhost ReWrite tab.
    Try going to www.yoursite.com and see if it maps to yoursite.com
    Then do the reverse - going to yoursite.com and see if it maps to www.yoursite.com. If they don't remap, then you don't have rewrites in place and there is your problem most likely.
    Either it should be set to strip the www from all inbound traffic or redirect it to a www format.
     
  7. florencia

    florencia Active Member

    Thank you Tracy for you detail answer. I talked to the hosting IT in arvixe and forwarded your suggestion. they took out the redirect. ;)
     
  8. Mike

    Mike XenForo Developer Staff Member

    The other common case is a reverse proxy which causes the IP to change (and also point to the reverse proxy, rather than the real client IP). Ideally, you'd want your web server to "trust" the forwarded IP and pass that information to PHP, but the alternative overwrites the $_SERVER['REMOTE_ADDR'] value in config.php.
     
  9. florencia

    florencia Active Member

    thank you Mike. When they took the redirect, the friendly URLs were not working. Now they fixed everything. I will check with the person that was having the login problem and let you know if the problem persists. I never had that issue. its strange that only a few users have it if its a server issue.
     
  10. Tracy Perry

    Tracy Perry Well-Known Member

    Actually, they don't need to remove the re-direct.
    You need to decide if you want your users directed to www.yourdomain.com or just yourdomain.com and place a redirect in their to keep it consistent. Where the problem comes in when there is not a redirect.
    If you go to www.servinglinux.com you will see that it redirects to servinglinux.com. I strip the www off all my forums (just looks cleaner to me).
     
  11. florencia

    florencia Active Member

    mmm I see. let me send this new information to hosting support. thank you
     

Share This Page