• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
LiteSpeed Cache - Community

LiteSpeed Cache - Community 1.0.4.3

No permission to download
#1
Michael A. submitted a new resource:

LiteSpeed Cache - Community - Quickly and easily implement high-performance page caching on your Xenforo forum

The LiteSpeed Cache Plugin for XenForo (LSCXF) is a PHP-based plugin that communicates with your installation of LiteSpeed Web Server(LSWS) and its built-in page cache, LSCache. Because LSCache is built directly into LSWS, overhead is significantly reduced and caching can be done more efficiently than with other PHP-based caches.

The current community version of LSCXF will only cache and serve pages for non-logged in users. After a user has logged in, their page requests will always hit the...
Read more about this resource...
 

ManagerJosh

Well-known member
#4
Ugh :(

LSCache Module. (Included with a 2-CPU or higher license. Can be purchased as an add-on for VPS, Ultra VPS, and 1-CPU licenses.)

Why can't the 1-CPU license have the LSCache Module too :(
 

Summit

Active member
#5
Question, I see the old LiteSpeed add-on was deleted, do i need to uninstall that one and reinstall with this one, or does an upgrade work just fine?
 
#6
Question, I see the old LiteSpeed add-on was deleted, do i need to uninstall that one and reinstall with this one, or does an upgrade work just fine?
Upgrading won't work in this case as the old LiteSpeed add-on was created by a 3rd party unrelated to LiteSpeed. The old add-on also contains some bugs fixed in this version so I would highly recommend deleting the old version and installing the official add-on :)
 

Peace

Active member
#16
Hi @Michael A. and @Slavik , thanks for releasing this! I upgraded LS to .12 and uninstalled the old plugin, removed the .htaccess line from old plugin too. Uploaded new plugin files and installed, now I cannot log out or in.

When I click log out, page just refreshes and I'm still logged in. With the old plugin, this would usually resolve itself after cache expired, but now it never logs out. Additionally if I open up the admin panel and login with my credentials, it just refreshes the page and I can't login.

Tried loading in incognito, can't login at all - I get this error:

Cookies are required to log in to this site. You will not be able to log in until they are accepted.
Any thoughts? We managed to get it working 100%, no logout issues, with nginx fastcgi, but we like Litespeed and would like to keep using it if possible when we migrate over to XF.

Thanks!
 
Last edited:

Peace

Active member
#17
By the way, some of my settings are a bit different, because of the recommended cache settings for vBulletin + LS Cache. Would any of the below conflict with this XF plugin?
upload_2016-2-7_22-58-5.png
 

Peace

Active member
#18
One other thing that breaks when I have the plugin enabled - on the registration form, the field validators all says "The field X was not recognised" (where X is a big string of numbers/letters). As soon as I disable the plugin, everything works fine again.
 

Peace

Active member
#20
Please follow cache policy mentioned here: https://www.litespeedtech.com/support/wiki/doku.php/litespeed_wiki:cache:lscxf:installation
Your current set up is not correct.

and make sure you have latest build 5.0.12, you can try to do lsup.sh -f -v 5.0.12

If there's still problem after you change, we can login & investigate your site.

Lauren
Hi Lauren, thanks for your reply! These were the settings I was given for LS cache on vBulletin. If I change them to match the installation guide, LS vB cache breaks, and LS xF cache still doesn't work.