Browser issue Latest Android Chrome keyboard suggestion issues

Affected version
1.5

thedude

Well-known member
#1
Android 8.1
Chrome 64.0.3282.137
Gboard keyboard 6.9

This started after a recent Android Chrome update a couple of weeks ago.

When making a post, pressing a suggestion at the top of the keyboard after typing in a word has either no effect on the word in the XF input field or jumbles the word with a mix of what was originally typed and the chosen suggestion.

This issue does not occur with Firefox for Android (the suggestion correctly replaces the originally typed word).

This issue doesn't affect XF 2.x
 

Goodfella

Well-known member
#3
Same here. And doubletapping space usually puts a period (.) At the end of a sentence. This seems to not work correctly either. At times a double tap of space will show as ( .). That's "blank space" then .
 

Joeychgo

Well-known member
#6
Same here -- I've had 2 complaints.

On user can't put an apostrophe in a word or it cuts off the following letter. Don't becomes Don'
 

radu81

Active member
#7
Same for me, and a couple of members also reported this.
Initially I thought it was a bug with Swiftkey, so o turned back to Google keyboard, but nothing changed.
Android 8.1 stock, latest version of Chrome
 
#10
I see the following (all intermittently) in the textbox on Disqus based comments
1. Double tapping space inserts a space then the period. No space after the period.
2. Tapping a suggestion on the suggestion bar does nothing. Mostly when the suggestion is just different capitalization. Typing 'nhl' shows 'NHL' on the suggestion bar. Taping the NHL, nothing happens
3. Tapping a suggestion on the suggestion bar doesn't replace the previously typed characters (the ones that generated the suggestion), with the suggestion. Rather it seems to add some semi-random characters(some but not all of the characters from the suggestion)
 

Mike

XenForo developer
Staff member
#11
I haven't been able to reproduce this, though it may be Android 8.x specific. Has anyone seen this on other versions of Android? Also, please confirm the keyboard(s) you've seen it with.

To clarify though, is this in any text box or is it specific to the rich text editor? If it's any "regular" input, this is very likely a regression in Chrome/Android somewhere as we don't really interact with basic entry at that level to my knowledge. In the RTE there is more JS running so it's possibly related though not definitive.
 

thedude

Well-known member
#12
I haven't been able to reproduce this, though it may be Android 8.x specific. Has anyone seen this on other versions of Android? Also, please confirm the keyboard(s) you've seen it with.

To clarify though, is this in any text box or is it specific to the rich text editor? If it's any "regular" input, this is very likely a regression in Chrome/Android somewhere as we don't really interact with basic entry at that level to my knowledge. In the RTE there is more JS running so it's possibly related though not definitive.
It's only in the rich text editor
 

ge66

Active member
#13
I have about ten users reporting this problem. It is only the rich text editor. They report garbeled text and some of the other problems mentioned in this thread. Some also say it is slow writing. Not sure if all is on swiftkey, but many. I have just asked about what android version they are using.
 

Joeychgo

Well-known member
#14
I have a user complaining of this who says: Samsung s 7 stock/default keyboard. He says android 7

Disabling the rich text editor fixed the problem for this user.
 
Last edited:

Goodfella

Well-known member
#15
I
I haven't been able to reproduce this, though it may be Android 8.x specific. Has anyone seen this on other versions of Android? Also, please confirm the keyboard(s) you've seen it with.

To clarify though, is this in any text box or is it specific to the rich text editor? If it's any "regular" input, this is very likely a regression in Chrome/Android somewhere as we don't really interact with basic entry at that level to my knowledge. In the RTE there is more JS running so it's possibly related though not definitive.
I'm on Android 7.0 using Google keyboard. Experiencing this in the rich text editor.


Not happening at he moment on here.
 

RobinHood

Well-known member
#16
Yeah, I have a user complaining about his text turning into gibberish, lots of letters being added. Android 7.0 and chrome. XF 1.5.13
 

Mike

XenForo developer
Staff member
#18
I've piggybacked an existing Chrome bug report, where an XF forum user reported issues on a specific forum, but I have derived a reduced test case and unfortunately, there's really nothing we can do in XF1 to fix it. It's specific to the approach used with the RTE there (which we moved away from in XF2). For reference, I can reproduce the issue in TinyMCE as well, which uses the same initialization method. It is by no means XF specific. The only workaround would be to disable the rich text editor while affected.

The bug is being tracked here: https://bugs.chromium.org/p/chromium/issues/detail?id=806309 I'll leave this open while awaiting a response.
 

radu81

Active member
#19
At least we know where is the bug, thanks for investigating.
I own 2 forums based on another script and I have the same problem, this bug made me crazy, I unistalled Swiftkey, unistalled all the apps on my phone in the end I did a full reset of my phone... and the problem is Chrome :)
 
Top