Importing from vBulletin 4.2.3 into Xenforo latest keeps failing

oneobgyn

Member
Hello
I am thinking there is a bug. I have tried twice to do an import from my vBulletin forum with it's 13 gig database. It has 11K members. The import hangs after about 1 hour, at step 16 of 32. A white screen. I have tried to restart, deleted the data and internal_data folders, then reimport but nothing runs beyond 1 hour.

This was on Xenforo latest with UI.X2 installed ready. But no members or data as the manual says to do. The next attempt was on a BLANK Xenforo install on another sub folder, and that import failed again. I am using the vBulletin importer V4 with blog, and retaining IDs, with writing a log file for the redirects as the V2 manual instructs.
The blog is actually very small, only 30 pages.

Then we got the web host to do it at their end, using the CLI importer and on a blank new Xenforo instal, and it failed for them as well. They have tried twice as well.

I am right now trying to import into Xenforo 1 last version before 2 came out, and that import has ran ok after 3 hours. BUT I am now worried about the IDs and the redirect scripts. Can someone come back on this? I am upset about this situation. We paid for the Xenforo licence, bought the Xenforo own plugins such as Gallery and super search. We are now in limbo.

Help please!!!!!!
 

oneobgyn

Member
Hi Ozzy47
No it just hangs, white screen. I am in the dark. The web host actually does vBulletin to Xenforo import as a free service. I think he did it on V1 but not V2. V2 won't work for him either. I must talk to Xenforo on the phone Monday and ask some questions. Right now I am doing it with V1 and then going to upgrade the instal to V2. My concern with that is the redirect scripts, I am unsure if V1 has that?
 

Chris D

XenForo developer
Staff member
Imports that fail at a white screen usually indicate server errors and usually the server will log them somewhere. Your host should check the web server / PHP error logs to see if anything is logged there.

However if the import works into XF1 and you upgrade to XF2 straight away then that’s a valid migration path and it should work out ok.
 

MySiteGuy

Well-known member
Sometimes it can be something as simple as an http or php process timeout. Or a max-packet length issue.

I've had an import hang with a white screen. Refreshing it, the import picked up where it left off. A check showed no records missing on the import. But I wouldn't do that with a large database, first find out why it failed, fix it and do it via the cli.
 

electric.larry

New member
I got a white screen as well, when I ran the import script. Turned out the php memory_limit was too low.

When starting the import from the browser, I had to add php_value memory_limit 2000M to the .htaccess file in xenforo's webroot.

When I'm starting the import from CLI I have to run php -d memory_limit=2000M cmd.php xf:import from xenforo's webroot to prevent the memory_limit overflow.

Maybe the memory limit does not have to be that high, but it kept failing when setting it below 1 GB.
 

MySiteGuy

Well-known member
Interesting, I wonder what's causing it to need so much? I've always managed to have it work for 256M (or less). Once you have everything working after an import, I'd set it back to something lower. This way if your site gets busy you won't risk running out of RAM and hitting the swap file. If some PHP processes get into a high memory condition in my opinion its better to error out than have it swamp the server's resources.
 
Top