XF 2.1 Avatar images blocky after importing from VBulletin 4

Foynat

Member
I imported my forum from VBulletin 4 yesterday. Everything went fine except users' avatars. The custom avatars are all blocky, it seems they were converted from JPG, GIF and PNG files to WEBP files. Also, the stock avatars which users were able to choose without uploading their own were not imported.

I did not have the Imagemagic extension installed, only GD, and I got a few errors about "RGB color profile cannot be applied" during the import.

My question is, can I install the Imagemagik extension and import just the avatars again? Would this be likely to improve the outcome? Obviously I don't want to change user's IDs or ruin my 301 redirections from the old VBulletin threads, so is this possible on an existing installation? I don't want to lose a day's posts by going back to the fresh installation either.

Also, is there any way of importing the shared avatars I had on VBulletin? I was thinking of uploading them to the Administrator's gallery so that users could manually download them and apply them as their avatars. Or is there a better way anyone knows of?

Thank you for any help anyone can give.
 

Brogan

XenForo moderator
Staff member
can I install the Imagemagik extension and import just the avatars again?
No, it isn't possible to re-run a single import step.

At this point it would likely just be better to tell the members to upload new avatars.
Or if you're feeling generous, you can do it for them in the ACP.

is there any way of importing the shared avatars I had on VBulletin?
XF doesn't have avatar gallery functionality.
You could create a page node and add them to that, which would allow members to use them.
 
Top