1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Friendly URL's Not Working

Discussion in 'Troubleshooting and Problems' started by chaseoes, Feb 23, 2014.

  1. chaseoes

    chaseoes Member

    I can't seem to get full friendly URL's working. When I attempt to visit any page other than the main homepage I'm greeted with a 404 error.

    I've tried the following:
    • Ensured my .htaccess file is writable, renamed htaccess.txt to .htaccess.
    • Enabled the friendly URL's option in the admin panel.
    • Ensured that mod_rewrite is enabled.
    • Ensured that AllowOverride is set to ALL.
    • Restarted Apache.
    • Followed applicable instructions in http://xenforo.com/help/friendly-urls/.
    Anything I'm missing?
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    I am able to browse any page on your site without a problem.
     
  3. chaseoes

    chaseoes Member

    Yes, it's in the root install folder with index.php.
     
  4. chaseoes

    chaseoes Member

    I'm trying to test it on a test installation before moving my live site.
     
  5. chaseoes

    chaseoes Member

    Anyone else have any ideas?
     
  6. AndyB

    AndyB Well-Known Member

    Contact your web hosting company and explain the problem.
     
  7. chaseoes

    chaseoes Member

    It's a dedicated sever, I'm my own web host.
     
  8. AndyB

    AndyB Well-Known Member

    I also have a dedicated server and get help from my web hosting company all the time.
     
  9. chaseoes

    chaseoes Member

    I'm not understanding. I don't have a web host. I installed Apache myself.
     
  10. Amaury

    Amaury Well-Known Member

    He hosts his own server, Andy. :)
     
  11. chaseoes

    chaseoes Member

    Anyone have ideas for what else I can try?
     
  12. Mike

    Mike XenForo Developer Staff Member

    You may need to set the RewriteBase in your .htaccess file.
     
  13. chaseoes

    chaseoes Member

    I set it to this:
    Code:
    RewriteBase /
    And it didn't change anything.
     
  14. chaseoes

    chaseoes Member

    I fixed it by adding the following to my default sites-available configuration in Apache:
    Code:
    <Directory /var/www/>
      Options Indexes FollowSymLinks MultiViews
      AllowOverride All
      Order allow,deny
      allow from all
    </Directory>
    Even though AllowOverride was set to all in the default Apache2 configuration apparently it needs to be set there as well.

    Thanks!
     

Share This Page