XF 1.2 Error in the admin cp after upgrade

russoroni

Active member
#1
Immediately after upgrading I get this error in the main screen in the admin cp:

Mysqli prepare error: Unknown column 'template_map.template_final' in 'field list'

  1. Zend_Db_Statement_Mysqli->_prepare() in Zend/Db/Statement.php at line 115
  2. Zend_Db_Statement->__construct() in Zend/Db/Adapter/Mysqli.php at line 381
  3. Zend_Db_Adapter_Mysqli->prepare() in Zend/Db/Adapter/Abstract.php at line 478
  4. Zend_Db_Adapter_Abstract->query() in XenForo/Model.php at line 219
  5. XenForo_Model->fetchAllKeyed() in TMS/Model/Template.php at line 228
  6. TMS_Model_Template->fetchAllKeyed() in XenForo/Model/Template.php at line 431
  7. XenForo_Model_Template->getOutdatedTemplates() in XenForo/ControllerAdmin/Home.php at line 26
  8. XenForo_ControllerAdmin_Home->actionIndex() in XenForo/FrontController.php at line 337
  9. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
  10. XenForo_FrontController->run() in /home1/russoron/public_html/admin.php at line 13

Any ideas?
 

Adam Howard

Well-known member
#2
Immediately after upgrading I get this error in the main screen in the admin cp:

Mysqli prepare error: Unknown column 'template_map.template_final' in 'field list'

  1. Zend_Db_Statement_Mysqli->_prepare() in Zend/Db/Statement.php at line 115
  2. Zend_Db_Statement->__construct() in Zend/Db/Adapter/Mysqli.php at line 381
  3. Zend_Db_Adapter_Mysqli->prepare() in Zend/Db/Adapter/Abstract.php at line 478
  4. Zend_Db_Adapter_Abstract->query() in XenForo/Model.php at line 219
  5. XenForo_Model->fetchAllKeyed() in TMS/Model/Template.php at line 228
  6. TMS_Model_Template->fetchAllKeyed() in XenForo/Model/Template.php at line 431
  7. XenForo_Model_Template->getOutdatedTemplates() in XenForo/ControllerAdmin/Home.php at line 26
  8. XenForo_ControllerAdmin_Home->actionIndex() in XenForo/FrontController.php at line 337
  9. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
  10. XenForo_FrontController->run() in /home1/russoron/public_html/admin.php at line 13
Any ideas?
Yes, I'm going to assume you upgraded from XenForo 1.1.x to XenForo 1.2.3

Some of the add-ons from 1.1.x are not compatible with 1.2.x Notably the TMS add-on I see in your error. There maybe more for that matter.

Add this inside your config.php file
PHP:
$config['enableListeners'] = false;
This will disable all your add-ons.

Next un-install the TMS as it is not compatible with XenForo (it has it's own template modification system).

Next, uncheck all your add-ons. Remove (or comment out) that line and slowly re-check your add-ons. You should update those which need it (technically you should keep all your add-ons updated).
 
Top