1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

As Designed custom profile fields not imported for user #1

Discussion in 'Resolved Bug Reports' started by EasyTarget, Oct 6, 2011.

  1. EasyTarget

    EasyTarget Well-Known Member

    Importing data from vB 3.6

    When installing v1.1 from a fresh install, the install asks you for the forum administrator i.e. user #1.

    If user #1 has the same username and email address but is not user #1 in vBulletin, the user merge doesn't import the custom profile fields for that user.
     
  2. Mike

    Mike XenForo Developer Staff Member

    That would be expected - you're merging into the existing user. We keep all of that user's data.
     
  3. EasyTarget

    EasyTarget Well-Known Member

    I don't think I explained it well....

    If user #1 is getting merged with user #8732; since user #1 is being set up when installing the forum, the software should use the responses in from user #8732.

    Considering when I set up the administrator I am not replying to all of the profile questions, just entering username, pwd, email address.

    Trivial, but still...
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

    As Mike said, the user from the vB installation (no matter the ID number) is being merged into the existing user in the XenForo installation.

    This will always be the case for the first user (administrator) created when installing XenForo.
     
  5. Mike

    Mike XenForo Developer Staff Member

    The user merging stuff is not specific to the first user - anyone can be merged if their name/email already exists. There's no way to know what is intentionally omitted vs not.
     
  6. EasyTarget

    EasyTarget Well-Known Member

    Ok, so the existing XF user wins, theoretically it will always impact the first user if you are importing from another forum.

    I understand. Thanks for the explanation.
     

Share This Page