• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.1 Crashing during upgrade.

Edrondol

Well-known member
#1
Here's the error:

Code:
Server Error
 
Mysqli statement execute error : Lost connection to MySQL server during query
 
Zend_Db_Statement_Mysqli->_execute() in Zend/Db/Statement.php at line 297
Zend_Db_Statement->execute() in Zend/Db/Adapter/Abstract.php at line 479
Zend_Db_Adapter_Abstract->query() in XenForo/Model/DataRegistry.php at line 164
XenForo_Model_DataRegistry->set() in XenForo/Model/Style.php at line 434
XenForo_Model_Style->rebuildStyleCache() in XenForo/DataWriter/Style.php at line 171
XenForo_DataWriter_Style->_rebuildCache() in XenForo/DataWriter/Style.php at line 162
XenForo_DataWriter_Style->_postSave() in XenForo/DataWriter.php at line 1385
XenForo_DataWriter->save() in XenForo/Model/StyleProperty.php at line 699
XenForo_Model_StyleProperty->updatePropertyCacheInStyle() in XenForo/Model/StyleProperty.php at line 632
XenForo_Model_StyleProperty->rebuildPropertyCacheInStyleAndChildren() in XenForo/Model/StyleProperty.php at line 2316
XenForo_Model_StyleProperty->importStylePropertiesFromArray() in XenForo/Model/StyleProperty.php at line 2187
XenForo_Model_StyleProperty->importStylePropertyXml() in XenForo/Model/StyleProperty.php at line 2120
XenForo_Model_StyleProperty->importStylePropertyDevelopmentXml() in XenForo/CacheRebuilder/ImportMasterData.php at line 45
XenForo_CacheRebuilder_ImportMasterData->rebuild() in XenForo/ControllerHelper/CacheRebuild.php at line 26
XenForo_ControllerHelper_CacheRebuild->rebuildCache() in XenForo/Install/Controller/Upgrade.php at line 232
XenForo_Install_Controller_Upgrade->actionRebuild() in XenForo/FrontController.php at line 310
XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132
XenForo_FrontController->run() in /home/davidn/public_html/xenforo/install/index.php at line 18
Any hints to tell my host what's up? I have a ticket open with just the error for now.
 

MattW

Well-known member
#3
You'll need to manually repair the table that is marked as crashed. Do that through phpMyAdmin if you have access to it.
 

Brogan

XenForo moderator
Staff member
#5
The search index table needs to be repaired at least.
The first problem indicates connection issues with the server during the cache rebuild.

Can you check and repair the DB and then try to rebuild the master data?
 

Edrondol

Well-known member
#13
Finally got into it thanks to the host helping out, truncated the table...and I still get the server error. So something else is going on. Yay! (Yes, I know this isn't an XF issue, but posting here has helped me narrow down what I needed to do.)
 

Mike Edge

Formerly Da Bookie Mon
#14
Any further idea's on this. We restarted MySQL, search index is empty, but he continues to get the error. Also MySQL logs don't show any issues resulting from this either.