1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Bounced Email Address

Discussion in 'XenForo Questions and Support' started by RoldanLT, Aug 6, 2014.

  1. RoldanLT

    RoldanLT Well-Known Member

    Is it fine to use normal gmail account?
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Yes.
     
    RoldanLT likes this.
  3. RoldanLT

    RoldanLT Well-Known Member

    How about: Automated Bounced Email Handler?
    Is it necessary?
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

    RoldanLT likes this.
  5. RoldanLT

    RoldanLT Well-Known Member

  6. RoldanLT

    RoldanLT Well-Known Member

  7. Brogan

    Brogan XenForo Moderator Staff Member

    IMAP
    Host: imap.gmail.com
    Port: 993
    Encryption: SSL

    POP3
    Host: pop.gmail.com
    Port: 995
    Encryption: SSL
     
  8. RoldanLT

    RoldanLT Well-Known Member

    I'm using IMAP, Don't know which one is the best to use :)
     
  9. dawg

    dawg Well-Known Member

    I think i have this working just tested it on a test account and indeed it locked the account down thats good. I have bounced emails forwarding to a bounce address in mandrill also. However, is says delivered yet there is no email in the bounce account? Does it just stay empty?
     
  10. Mike

    Mike XenForo Developer Staff Member

    I'm confused. Half of your message implied that it worked correctly:
    And then half implied that no email was received (thus it couldn't have worked):
    Are these referring to the same thing?

    When XF processes mail, the mail is removed from the mailbox. You can see it in the bounce processing logs.
     
  11. zastavra

    zastavra Formally Stevez

    I have tried everything but I can't make it work. Can you please tell me if there is something wrong with my settings?

    [​IMG]
     
  12. Mike

    Mike XenForo Developer Staff Member

    It's not clear what issue you're having. What element isn't working (and what makes you think that)? Are you receiving any errors?
     
  13. zastavra

    zastavra Formally Stevez

    I have created a couple of testing accounts with fake email addresses requesting email confirmation, but I'm getting no bounced returns or any action from xf automated bounced email system.
     
  14. Mike

    Mike XenForo Developer Staff Member

    Have you confirmed they were received by the bounce account? (Note that in some circumstances, connecting to the account may mean that XF doesn't see the messages. This is more for POP3 though.)

    If so and the bounce cron has run, are there any errors logged? Are there any entries in the bounce log?
     
  15. zastavra

    zastavra Formally Stevez

    No, I'm not receiving anything related with the testing accounts.
    I just set IMAP for few hours. I'm using POP (110) setting.
    I just it manually again right now. No server errors or entries in the bounce log except a couple entries from spam emails marked with "no action" .
     
    Last edited: Sep 12, 2014
  16. TDUBS

    TDUBS Active Member

    This is somewhat off-topic, but be careful using mail servers like Gmail and Outlook for sending out mass emails such as verification emails to complete forum registration. When I was using the http://domains.live.com mail server, they suspended my email because it was "sending out too many messages at once." I don't know Gmails TOS, but I'd just double check it.
     
  17. Mike

    Mike XenForo Developer Staff Member

    That's the problem. Since you mentioned entries in the bounce log, that side is working correctly.

    You need to check that emails sent from your forum have the correct Return-Path header (it will be near the top of the headers). It's possible the mail service you're using is blocking or rewriting it. (We normally recommend sending through the default PHP method rather than an external SMTP server. Make sure you enable -f for that if you do try to switch to it.)
     
    zastavra likes this.
  18. dawg

    dawg Well-Known Member

    I got a little confused myself. However, going back over your posts and instructions on this feature i see that it is working perfectly. Thanks again for all the help.
     
  19. zastavra

    zastavra Formally Stevez

  20. clove28

    clove28 Active Member

    Hi. I'm getting this error. Did I enter the details correctly?

    Code:
    Error Info
     
    Zend_Mail_Protocol_Exception: cannot connect to host; error = Connection timed out (errno = 110 ) - library/Zend/Mail/Protocol/Imap.php:100
    Generated By: Unknown Account, 23 minutes ago
     
     
    Stack Trace
     
    #0 /public_html/library/Zend/Mail/Storage/Imap.php(273): Zend_Mail_Protocol_Imap->connect('imap.gmail.com', 993, 'SSL')
    #1 /public_html/library/XenForo/Model/EmailBounce.php(292): Zend_Mail_Storage_Imap->__construct(Array)
    #2/public_html/library/XenForo/Deferred/EmailBounce.php(19): XenForo_Model_EmailBounce->openBounceHandlerConnection()
    #3 /public_html/library/XenForo/Model/Deferred.php(256): XenForo_Deferred_EmailBounce->execute(Array, Array, 7.9999980926514, '')
    #4/public_html/library/XenForo/Model/Deferred.php(390): XenForo_Model_Deferred->runDeferred(Array, 7.9999980926514, '', false)
    #5 /public_html/library/XenForo/Model/Deferred.php(335): XenForo_Model_Deferred->_runInternal(Array, NULL, '', false)
    #6 /public_html/deferred.php(23): XenForo_Model_Deferred->run(false)
    #7 {main}
     
     
    Request State
     
    array(3) {
      ["url"] => string(43) "http://www.pinoyexpatforum.com/deferred.php"
      ["_GET"] => array(0) {
      }
      ["_POST"] => array(4) {
        ["_xfRequestUri"] => string(47) "/index.php?threads/forum-rules-guidelines.2618/"
        ["_xfNoRedirect"] => string(1) "1"
        ["_xfToken"] => string(8) "********"
        ["_xfResponseType"] => string(4) "json"
      }
    }
    
    bounce.jpg
     

Share This Page