Resource icon

[bd] Widget Framework 2.6.3

No permission to download
Agreed, also very irresponsible to run software that has not been updated for security vulnerabilities since Aug 2014 over THREE YEARS ago! Even at that time 25 potentially security related fixes were backported from PHP 5.4 and 5.5 to 5.3.29. Just think how many have accumulated since then!
Looking at the positive side... guess what! I survived! :giggle:
 
@xfrocks I am trying to upgrade from 2.5.9 to 2.6.3. However, as soon as I uploaded the files for 2.6.3, I got a 500 error in the admin control panel. I pulled up the error log and it said:

PHP Fatal error: Cannot access self:: when no class scope is active in domain/public_html/library/WidgetFramework/ShippableHelper/Updater.php on line 79

I never even had a chance to run the XML file in the control panel, because simply uploading the new files caused the control panel to return the 500 error. I ended up re-uploading the files from the 2.5.9 version, and that fixed the error.

What would cause this error to occur, and can anything be done so that I can upgrade the plugin? I am using the latest version of Xenforo, Xenforo 1.5.16.

Thank you!
 
Last edited:
@xfrocks

I am getting ErrorException: Undefined index: https://xfrocks.com/api/index.php?updater - library/WidgetFramework/ShippableHelper/UpdaterCore.php:408

even though the updater is not enabled in the debug options.

Any ideas? It's causing me problems...

Thanks :)

Edit: seems that the error has gone away now (without me changing anything).

Another question:
Is there any widget which works exactly as the native last posts block? From those I tested they will either show newly created topics or replies. Not both.

and lastly, I believe there is a bug in the positioning. Sometimes when visiting a deeplink (#....) the widgets overlap other elements.
 
Last edited:
I'd love a little more information on how to apply conditionals for this.

For example, I tried using the following to display the tagcloud from [Tinhte] tags:

{$forum.parent_node_id} == x

where x would be a number, ie, 16 in this instance.

But I'm getting that bounced back as incorrect syntax.

I did get it to work when I used the following:

{$forum.node_id} == '38'

So it would display on a specific forum list. However, I couldn't designate multiple forum lists, using the following different expressions:

$forum['parent_node_id'] == '38,298,92,36,37,94,34,387'
in_array($forum['node_id'], array(38,298,92,36,37,94,34,387))

What I wanted to do was display the tagcloud in the sidebar for posts in a particular category for a particular theme, but I can't seem to apply multiple node values, nor have the syntax recognised.

Further pointers would certainly be welcome!
This conditional works for me and it is same as one of yours
Code:
in_array($forum['node_id'], array(27,29))
But I use the Feed Reader renderer, not the Tag Cloud, so maybe that's a problem.
Are you positions set correctly, i.e forum_view, thread_view etc....
 

ibrian

Well-known member
This conditional works for me and it is same as one of yours
Code:
in_array($forum['node_id'], array(27,29))
But I use the Feed Reader renderer, not the Tag Cloud, so maybe that's a problem.
Are you positions set correctly, i.e forum_view, thread_view etc....
Cheers - that's what I tried for the tag cloud, but get the following error:

WidgetFramework_Helper_Conditional - Line 1: Invalid condition expression
 

xfrocks

Well-known member
Cheers - that's what I tried for the tag cloud, but get the following error:
@ibrian The last update of [bd] Widgets Framework, seems to have deprecated expressions such as yours (and mine).
Maybe that's the reason, because I didn't upgrade (yet)

- Changed: Expression is deprecated, it’s recommended to use Conditionals
Yes, expression is deprecated. If your widget is already using some, they will continue to work but you cannot add expression for new widget. The conditional equivalent is

Code:
in_array({$forum.node_id}, {xen:array '0=27', '1=29'})
 
I am getting errors when trying to add a wiget based on PHP callback. Error message "Please enter a valid callback function". However, there are no fields to enter the callback function. Any idea what I can do? @xfrocks
 

xfrocks

Well-known member
@xfrocks

Still getting ErrorException: Undefined index: https://xfrocks.com/api/index.php?updater - library/WidgetFramework/ShippableHelper/UpdaterCore.php:408

even though the updater is not enabled in the debug options...

After restarting the webserver the error goes away until later on. Could it be caching issue?
Can you double check the Debug options page? If the option is unchecked, it should not be running at all.

I am getting errors when trying to add a wiget based on PHP callback. Error message "Please enter a valid callback function". However, there are no fields to enter the callback function. Any idea what I can do? @xfrocks
This looks like a bug, new version will be released to fix it. Sorry for the inconvenience.
 
I have a widget group with 5 tabs

widgetf-tabs-member.png

How can I hide 4 tabs of this group for guests?
widgetf-tabs-guests.png
I tried with these conditions. Unfortunately it does not work


You can use widget groups for that. Make one widget for guests and another for members. Both in the same group. Use the conditional field to apply usergroup permissions.
{$visitor.user_id} > 0 (show up for logged in users only)
{$visitor.user_id} == 0 (show up for logged out users only)
Widget Framework 2.6.3
PHP Version 5.6.30-0+deb8u1
XenForo 15.16


Thanks:)
 
Last edited:

eva2000

Well-known member
I seem to be getting this error logged in my xenforo server log and i believe it's related to conditional i am using in a widget

Advance HTML & Template, on edit template conditional field I added

Code:
!in_array({$contentTemplate}, array('member_view', 'message_page', 'error', 'search_form', 'search_form_post', 'search_form_profile_post', 'search_results', 'register_form', 'register_facebook', 'register_twitter', 'register_google', 'login', 'login_two_step', 'error_with_login', 'contact', '_page_node.37', '_page_node.40', '_page_node.42'))
Code:
Error Info
ErrorException: Undefined variable: contentTemplate - library/WidgetFramework/Helper/Conditional.php(20) : eval()'d code:2
Generated By: Unknown Account, A moment ago
Stack Trace
#0 .../library/WidgetFramework/Helper/Conditional.php(20) : eval()'d code(2): XenForo_Application::handlePhpError(8, 'Undefined varia...', '.../dom...', 2, Array)
#1 .../library/WidgetFramework/Helper/Conditional.php(20): eval()
#2 .../library/WidgetFramework/WidgetRenderer.php(581): WidgetFramework_Helper_Conditional::test('!in_array({$con...', '$__output = '';...', Array)
#3 .../library/WidgetFramework/WidgetRenderer.php(665): WidgetFramework_WidgetRenderer->_testConditional(Array, Array)
#4 .../library/WidgetFramework/Core.php(519): WidgetFramework_WidgetRenderer->render(Array, 'thread_view', Array, Object(XenForo_Template_Public), Object(_WidgetFramework_ArrayOfString))
#5 .../library/WidgetFramework/Core.php(481): WidgetFramework_Core->renderWidget(Array, 'thread_view', Array, Object(XenForo_Template_Public), Object(_WidgetFramework_ArrayOfString))
#6 .../library/WidgetFramework/Core.php(448): WidgetFramework_Core->renderWidgets(Array, 'thread_view', Array, Object(XenForo_Template_Public), Object(_WidgetFramework_ArrayOfString))
#7 .../library/WidgetFramework/Core.php(327): WidgetFramework_Core->_renderWidgetsFor('thread_view', Array, Object(XenForo_Template_Public), Object(_WidgetFramework_ArrayOfString))
#8 .../library/WidgetFramework/Listener.php(133): WidgetFramework_Core->renderWidgetsFor('thread_view', Array, Object(XenForo_Template_Public), Array)
#9 .../library/XenForo/CodeEvent.php(58): WidgetFramework_Listener::template_post_render('thread_view', '\n\n\t\n\t\n\n\n\n\n\n\n\n\n\n...', Array, Object(XenForo_Template_Public))
#10 .../library/XenForo/Template/Abstract.php(205): XenForo_CodeEvent::fire('template_post_r...', Array, 'thread_view')
#11 .../library/XenForo/Template/Public.php(110): XenForo_Template_Abstract->render()
#12 .../library/XenForo/ViewRenderer/HtmlPublic.php(124): XenForo_Template_Public->render()
#13 .../library/XenForo/FrontController.php(662): XenForo_ViewRenderer_HtmlPublic->renderContainer(Object(XenForo_Template_Public), Array)
#14 .../library/XenForo/FrontController.php(176): XenForo_FrontController->renderView(Object(XenForo_ControllerResponse_View), Object(XenForo_ViewRenderer_HtmlPublic), Array)
#15 .../index.php(13): XenForo_FrontController->run()
#16 {main}
Request State
array(3) {
  ["url"] => string(127) "https://domain.com/threads/patch-use-chacha20-poly1305-if-its-the-clients-most-preferred-cipher-openssl-1-1.8603/"
  ["_GET"] => array(1) {
    ["/threads/patch-use-chacha20-poly1305-if-its-the-clients-most-preferred-cipher-openssl-1-1_8603/"] => string(0) ""
  }
  ["_POST"] => array(0) {
  }
}
what should the conditional be ? it's for excluding an sidebar displayed advertisement from certain pages of the forum.

Using

Xenforo 1.5.16a with Widget Framework 2.6.3
 
Top