XF 2.0 After Upgrading to XF2, CloudFlare is not working Please advice

bomb2060

New member
Has anyone been getting weird broken pages with CloudFlare enabled? I'm on Xen2 with CloudFlare, just after enabling CloudFlare my pages go weird... not sure if it's xf2 bug or what? Kindly but urgently advice.
 

mmcguire

Member
Yes I have seen the same thing. I am just testing out beta 4 and behind CloudFlare I get pages like this:

Screen Shot 2017-09-28 at 7.54.36 AM.png

When I edit my local hosts file and skip CloudFlare the site looks normal.
 

Mike

XenForo developer
Staff member
We know what causes it, but I'd like to be able to attempt to do some debugging. Would it be possible for you to provide FTP details to the site that's currently having the problem? If so, can you submit a ticket with that information?
 

mmcguire

Member
Sorry I am testing on a host with that does not have FTP. Its pretty locked down with a single account with jailed SFTP access only. The other accounts are limited to key and a 2nd authentication methods only.
 

Brad Padgett

Well-known member
Yes I use CF SSL and a self-signed certificate between CF and my server.
Well I'm going to redirect it anyway. I use the same thing. I should be okay since I have all the performance stuff off such as rocket loader and cached css.

Let's hope for the best!
 

carntheroos4eva

Active member
Thanks for the reply. I don't think I should have an issue. I just wanted to ask since it was a labeled bug.

I never had any of that enabled. I learned the hard way a long time ago CF and it's caching issues.
Try going with the one your host uses and do that after you have installed your version of xf software.
 

Brad Padgett

Well-known member
Try going with the one your host uses and do that after you have installed your version of xf software.
I just tried and didn't have any issues. Worked just like I intended it. I'm using cloudflares SSL and everything went smoothly. I assume its because I had the performance enhancements disabled.
 

Mike

XenForo developer
Staff member
The screenshot shown is a CloudFlare bug. Disable "Minify CSS" to workaround it. (You may need to clear your browser cache.)

They have apparently fixed it, though I'm not sure when that will fully roll out.
 

Nirjonadda

Well-known member
The screenshot shown is a CloudFlare bug. Disable "Minify CSS" to workaround it. (You may need to clear your browser cache.)

They have apparently fixed it, though I'm not sure when that will fully roll out.
I have the same issue then disabled Auto Minify all option and get working. So only need uncheck "CSS" box?

ScreenShot00028.png
 
Last edited:
Top