Add Skimlinks Code

Add Skimlinks Code 1.4.0

No permission to download

Mackeral_Fillet

Well-known member
I've been using this for years with great results. However today I noticed that some links are giving this error upon clicking:

Code:
Microsoft VBScript runtime error '800a01a8'

Object required: 'domXML.documentElement.SelectSingleNode(...)'

/entrytag.asp, line 145
Any ideas what this means?
 

dougdirac

Active member
Setting up for our site for SSL and I'm getting mixed content warnings. Looks like the skimlinks .js is loading over http instead of https.
 

dougdirac

Active member
Setting up for our site for SSL and I'm getting mixed content warnings. Looks like the skimlinks .js is loading over http instead of https.
So I fixed this by editing the xml file. There are 3 instances of "http://" that should be replaced with "//" (without the quotes).
Would be cool if the download was updated to include this. :)
 

clackey

Member
Having some issues with one of the users on my site getting warnings from his cisco security about skimlinks using this addon. Submitted a ticked to skimlinks and this is their response. I'll probably try and change this myself but thought you might want to update the addon as well.


The technical support team have noticed that this could be the result of using the older version of the Javascript.

Currently you ate using:

<script type="text/javascript" src="http://s.skimresources.com/js/74150X1555440.skimlinks.js"></script>

If you can change this to:

<script type="text/javascript" src="//s.skimresources.com/js/74150X1555440.skimlinks.js"></script>
 

Stuart Wright

Well-known member
@Chris D is this addon inserting the skimlinks code onto every page including those added by custom addons like the Showcase or our editorial? Or do we need to manually add it there?
 

Chris D

XenForo developer
Staff member
You may need to add it to the editorial, if that uses a custom PAGE_CONTAINER (I think it does), otherwise, yes, it should be on every page automatically.
 

dougdirac

Active member
Having some issues with one of the users on my site getting warnings from his cisco security about skimlinks using this addon. Submitted a ticked to skimlinks and this is their response. I'll probably try and change this myself but thought you might want to update the addon as well.
...
I pointed out the https issue in the post above yours some 8 months ago.
 

dutchbb

Well-known member
I pointed out the https issue in the post above yours some 8 months ago.
Fixed this in the skimlinks_js_footer template.

Just change to https:

<xen:if is="{xen:helper ismemberof, $visitor, $xenOptions.skimlinksGroupSelector} AND {$xenOptions.skimlinksID}">
<xen:if is="{$forum}">
<xen:if is="!in_array({$forum.node_id}, {$xenOptions.skimlinksCodeForumSelector})">
<script type="text/javascript" src="https://s.skimresources.com/js/{xen:jsescape $xenOptions.skimlinksID}.skimlinks.js"></script>
</xen:if>
<xen:else />
<script type="text/javascript" src="https://s.skimresources.com/js/{xen:jsescape $xenOptions.skimlinksID}.skimlinks.js"></script>
</xen:if>
</xen:if>
 

Donny

Active member
I have a bit of an issue with Skimlinks, being in the UK. Apparently Amazon UK and EU have stopped working with Skimlinks on a link-skimming basis. And skimwords doesn't work with XF. Skimlinks showcase 'tools' show Amazon UK in them on my sites, and I'm not getting paid commission from Amazon via them. So their showcase thing is basically useless for me too.

So at the moment, it's pretty much only serving as an eBay link-skimming service. And with link proxies active and talk about that not delivering full revenue, I'm seriously wondering why I'm still using it.

Is there anything I can do to either get Amazon working again, or get Skimwords working? Or is it time to look for some other way to gain revenue from my Amazon and eBay links?
 

Chris D

XenForo developer
Staff member
With regards to the specifics of their service you would be better contacting them directly.

They may be able to provide updates configurations on what might work or have info on what your alternatives are.
 

Donny

Active member
Ahhh sorry Chris, I thought this was their own Add-on for a moment then! I've already got a ticket open with them. But they seem quite vague in what's going on. I think Amazon have just dropped them to be honest and they don't want to say.

I've created a thread in the management forums to see if somebody else with UK forums has hit the same issue, and how they got around it. That's probably my best shot. :)

Cheers for clearing that up though. Good job I didn't go full-on-volcano in my post eh? I'd have felt silly just now.
 

dutchbb

Well-known member
When using convert url to title some links do not work when you click on them (go's to broken tradetracker page).

Edit: Looks like it has nothing to do with that but something with skimlinks today (before no problems).
 
Last edited:

Chris D

XenForo developer
Staff member
I doubt it. I’d honestly just recommend using template edits to add the code provided by Skimlinks. It’s very easy and you likely won’t have to worry too much about outdated templates and merging etc.
 
Top