[8WR] XenPorta (Portal) PRO

[8WR] XenPorta (Portal) PRO [Paid] 1.2.2b

No permission to buy ($40.00)
@Jaxel

We upgraded from Xenporta 1 to Xenporta 2. We're trying to promote a thread to an article, but it doesn't update the Articles Layout after we save. Ie it still shows the previously promoted thread.
What should we be looking at to debug this issue?

thank you!
 

Jaxel

Well-known member
Sorry guys, I'm currently broadcasting in St. Maarten for the next 3 weeks and won't really be able to give any direct support. I'll be reading the forums, but I won't really be able to help anyone. Don't worry, I'll get back to things when I return to the states.

http://sxmcarnival.tv
 

Lone Wolf

Well-known member
Jaxel said:
  • Removed the "Show Full-sized Article Icons" option. It confused people and was really only in there for expert users; but expert users could do what the option did, without the option. So it was pointless.
I was using this to use attachments on article previews. I updated and the default thumbnails are being stretched and they look very blurry.
 

rv65

Active member
How do you make Xenporta as site index page? I am going to migrate to XF, and it will be a different directory, and would like to use the existing html directory for the index page.
 

MMAcomm

Active member
@Jaxel I know you are away, but you might like to know that when an article is featured it breaks the @sonnb live thread mod.

The reason I think this is worth looking into (even though its a mod/mod interference that devs don't like to deal with for many good reasons) is that even after REMOVING the featured thread, the thread remains tainted and breaks the live thread.

Make thread -> feature thread -> make it live -> ajax refresh timer happens but the thread refreshes and turns off the live thread mod.

Okay, no big deal, I thought I would just remove the featuring of this thread.
The same behavior occurs.

So then I made a thread. Featured it.Removed it. Try live. Its broken. Something is being altered that doesn't return to normal.

Live thread works fine for all thread that aren't featured.

I was able to create a new thread, and merge those old posts into it and the live thread works again.

In my opinion, I think its fair to ask that after a thread is un-featured or un-promoted that it should remain in the same state that it was prior to that feature/promotion. It would be much more expected behavior. This is one mod error, but I worry about others in the future. Consider this for an update. Have a good trip.
 

Jaxel

Well-known member
In my opinion, I think its fair to ask that after a thread is un-featured or un-promoted that it should remain in the same state that it was prior to that feature/promotion. It would be much more expected behavior. This is one mod error, but I worry about others in the future. Consider this for an update. Have a good trip.
When an article is is un-promoted or un-featured, any reference to it every being so gets deleted. Including category links and alerts... So the error you are seeing doesn't really make much sense unless its a javascript caching issue.
 

MMAcomm

Active member
When an article is is un-promoted or un-featured, any reference to it every being so gets deleted. Including category links and alerts... So the error you are seeing doesn't really make much sense unless its a javascript caching issue.
I'm not near educated enough to point out the exact reason, but I have tested this about 10 different ways and took my entire forum apart including themes and disabling and enabling every single add-on in a slow and steady fashion to make sure this is the behavior that is happening.

It is what it is.

Feature the thread, unfeature the thread... something afterwards is left that is breaking the other mod. I don't really know enough about javascript caching for that to make any sense to me. But if there is a way to remove fingerprints on anything, including that, I would ask you to see if there is any house keeping you can do that might fix this, admittedly odd, issue.
 
The included Teamspeak Addon is .....

upload_2015-4-19_6-59-32.png

Not very interested in staying where it's supposed to

also I were wondering if there was a way you can "port" Widget Framework widgets over to Xenporta 2.0 :)
 
Last edited:

Zackerykr

Member
I've been trying to figure this out for a while now without much luck. It's probably a stupid question to ask, and it's probably really easy to do, but how do I make a page within Xenforo that only displays widgets like the Article List? Any help would be greatly appreciated.
 
I've been trying to figure this out for a while now without much luck. It's probably a stupid question to ask, and it's probably really easy to do, but how do I make a page within Xenforo that only displays widgets like the Article List? Any help would be greatly appreciated.
Hi there, I'm admittedly very tired so I'll try to explain it in as simple a way as possible.
he shows a pretty good video on how he actually hooked that exact page up to Xenporta 2 in one of his guide videos, but you don't need worry about that, he did that for you.

upload_2015-4-20_23-16-15.png

first go into Xenporta 2 options and make sure Page View got a tick.

after doing that are we interested in going into the tab called "Layouts"
and create a "new layout"

you will need to put in pagenode_container in the box called Template, the rest doesn't matter and the Evaluation should just be left blank, that's only for doing a bit more specific setup.

upload_2015-4-20_23-19-32.png

you can read more about the advanced "Evaluation Arguements in his FAQ

With that being done should you simply be able to fill out the Layout as you so please.

And the end result in my case ended up looking a bit like this

upload_2015-4-20_23-24-36.png


Feel free to post if you have further questions regarding the subject at hand

With Love
//Nyx
 

Zackerykr

Member
Hi there, I'm admittedly very tired so I'll try to explain it in as simple a way as possible.
he shows a pretty good video on how he actually hooked that exact page up to Xenporta 2 in one of his guide videos, but you don't need worry about that, he did that for you.


first go into Xenporta 2 options and make sure Page View got a tick.

after doing that are we interested in going into the tab called "Layouts"
and create a "new layout"

you will need to put in pagenode_container in the box called Template, the rest doesn't matter and the Evaluation should just be left blank, that's only for doing a bit more specific setup.


you can read more about the advanced "Evaluation Arguements in his FAQ

With that being done should you simply be able to fill out the Layout as you so please.

And the end result in my case ended up looking a bit like this

View attachment 104197


Feel free to post if you have further questions regarding the subject at hand

With Love
//Nyx
How to I find the node ID for the eval arguments?
 

Zackerykr

Member
@PhantomOfNyx quick question, is there a way to use the old XenPorta donation block on XP2 or am I missing something? Thanks for the great answer to my last question by the way, it helped me out a ton.
 
@PhantomOfNyx quick question, is there a way to use the old XenPorta donation block on XP2 or am I missing something? Thanks for the great answer to my last question by the way, it helped me out a ton.
Hi there @Zackerykr
As far as I know is XP addons not compatible with Xenporta 2
(I've only been using Xenporta 2 myself for a few days )

I don't know if you are talking about the Paid Addon (Donation Manager ) which sidebars are ofcourse removed when you mark that you want to remove all sidebars.

however if you are talking about a 3rd party plugin which was written for Xenporta can I suggest one of the following options
You can install Widget Framework alongside Xenporta 2 ( which I have done ) and use Widget framework for those few sidebars Xenporta 2 doesn't provide yet, you have to keep in mind Xenporta 2 is still pretty new, and Widget Framework have been around for a long time, and you can easily hook widget framework blocks into the Xenporta frontpage ^_^

Another option would be if it is indeed in fact the donation manager framework am I certain this would be a pretty popular addon, and upon request do I think there can quite easily be made a plugin for Xenporta 2 for it.

I for now assuming it's not Donation manager but another 3rd party addon (block) made for Xenporta1 would try to lookup something simmiliar for widget framework

Or if you ask nicely if you provide the proper details in a PM, can I probably whip something up for you for Xenporta 2

you will have to ask nicely though, and a fair warning been a while since I coded. ;)

With Love
//Nyx
 

CoZmicShReddeR

Well-known member
Do you want extra Raw HTML blocks? You can use option sets to do that
There is no way to show extra HTML blocks with Option sets! You can only switch back and forth as far as I can see it's not what I want!

We need like a way to just add more custom HTML blocks really shouldn't be that hard for the author to add this feature since he made one he can make more or add a function to create more.
 
Top