[8WR] XenPorta (Portal) PRO

[8WR] XenPorta (Portal) PRO [Paid] 1.2.2b

No permission to buy ($40.00)

dondomainer

Active member
@Jaxel - here is something that I have never tried with xenporta2.

I am trying to make the user register to read so i change the "View topic content" permit to non, The titles continue to appear on thread_list (that is ok ), but disappearing from "xenporta Articlelist"

plz, what i can do ?
 

SeToY

Active member
Hey,

I'm using ThemeHouse's "Monetize Pro" Ad Manager. When specifying the zone "Below Content" the ads are correctly displayed "above the footer" in the forums. However, in XenPorta, it's below the left side of the widget area.

Can this bug be fixed? :) Thanks!
 

NinaMcI

Active member
Hi. I hope someone can help me. I'm using the Users Active Today widget and I would like to show a specific custom user field next to each member displayed in the list. Is this possible and, if so, how can I achieve this?
Thanks
 

JacquiiDesigns

Formerly MsJacquiiC
"Promote to Article" & "Promote to Feature" links have seemingly disappeared. I don't see any reason why/how this could happen. I'm Super Administrator and permissions are set correctly. I've just posted a news announcement and would like to promote it to an article. Only I don't see the links in the "Thread Tools" dropdown.

Please help. Thanks @Jaxel

J.
 

JacquiiDesigns

Formerly MsJacquiiC
"Promote to Article" & "Promote to Feature" links have seemingly disappeared. I don't see any reason why/how this could happen. I'm Super Administrator and permissions are set correctly. I've just posted a news announcement and would like to promote it to an article. Only I don't see the links in the "Thread Tools" dropdown.

Please help. Thanks @Jaxel

J.
Hello? Can anyone assist with the above issue please?
Thanks!

J.
 

JacquiiDesigns

Formerly MsJacquiiC
Try running analyze permissions (ACP > Groups and Permissions > Analyze permissions > username) to make sure you have the right effective permissions
Wow. So simple and I didn't even realize or think of sorta 'contradictory' permissions.
But my "Premium" usergroup (which I'm a part of) had permissions for the XP2 options set to "Never"
Once I switched the settings to "Not Set/No" - the Promote To Article links appeared as they should.
Thanks so much @rfc0001 for the suggestion and indeed the "fix" ... I appreciate ya ;)

J.
 

rfc0001

Well-known member
Wow. So simple and I didn't even realize or think of sorta 'contradictory' permissions.
But my "Premium" usergroup (which I'm a part of) had permissions for the XP2 options set to "Never"
Once I switched the settings to "Not Set/No" - the Promote To Article links appeared as they should.
Thanks so much @rfc0001 for the suggestion and indeed the "fix" ... I appreciate ya ;)

J.
Yep - Never really means Never :p
 

Mellow1234

Member
Sorry, this is way more feature rich and complicated than I need... I simply need a home page where I can place some html in blocks and maybe show site states and a few recent posts. This is so involved it's going to be tough to keep track of .. anyone have a suggestion for something simpler? This is a great product but just too much for what I need. I wish I could have figured that out before I purchased it.. maybe i can transfer my license or get a refund?
 

JacquiiDesigns

Formerly MsJacquiiC
Sorry, this is way more feature rich and complicated than I need... I simply need a home page where I can place some html in blocks and maybe show site states and a few recent posts. This is so involved it's going to be tough to keep track of .. anyone have a suggestion for something simpler? This is a great product but just too much for what I need. I wish I could have figured that out before I purchased it.. maybe i can transfer my license or get a refund?
Well... You're not compelled to use all the features.
It's quite simple to create a couple html blocks on the homepage using XenPorta Pro.
You could also simply create a page with the html in it and route it to be your homepage if you're looking for something quite simple.
HTH,

J.
 

upnet

Active member
Can anyone advise how to change the opacity/transparency of the background of the summary container on the feature slider? We are trying to make the text pop more, and with the current opacity of the black background, and the white text, it doesn't read clearly. Any other advice on how to handle the excerpt text of the feature slider is also welcome.

Also, I have watched the tutorial videos, but cannot figure out how to change the article layout so that it does not show the recent posts between the article and the comments. Any obvious thing I might be missing?
 
Last edited:

Live Free

Active member
@dondomainer, I realize you may have solved this buy now but I just spent time figuring it out myself. I didn't seen any answers when skimming the thread. Hopefully this can help you or someone else.

For both problems, there are a few approaches that could work, and most that I tried. 1) Conditional if or if/else statements checking against the template name, CSS hacks [i.e. display:none], and the solution I settled for last, simply commenting out the code.

Question to advance users :

How hide breadcum and title from home?


I found this for title on forum :

Code:
.forum_list .titleBar h1 {
font-size: 0px;
}
but only work on forum page, no for xenporta2 homepage
Scanning this thread, it doesn't appear your question was answered. I just spent an hour+ figuring this out, so maybe this can help somebody out. Here a walkthrough of my solution:

1. Identify the template you want to hide the board title on. If you want to hide it from the portal home, I think you should use the EWRporta2_ArticleList template. Template names are conveniently located next to the layout name, in gray (Xenporta2 > Layouts). (In my case, I needed to hide it from the article pages for one of my layouts, so I used EWRporta2_ArticleView).

On the first few lines of the template, you'll find the following code:

Code:
<xen:title>{xen:helper threadPrefix, $thread, escaped}{$thread.title}{xen:helper pagenumber, $page}</xen:title>
<xen:h1>{xen:helper threadPrefix, $thread}{$thread.title}</xen:h1>
Comment out the contents of the H1 tag, like so:

Code:
<xen:title>{xen:helper threadPrefix, $thread, escaped}{$thread.title}{xen:helper pagenumber, $page}</xen:title>
<xen:h1><xen:comment>{xen:helper threadPrefix, $thread}{$thread.title}</xen:comment></xen:h1>
This worked for me.

I started by looking for {$xenOptions.boardTitle} in XenPorta2 templates and couldn't find it, and when I did, I couldn't get conditional statements or even deleting it to work. No dice.

Turns out it was an exercise in futility. As mentioned later in this thread, the forum title will automatically reappear unless you keep the empty H1 tags. Which is why this took me so long to figure out. No clue why.


and this for breadcum on forum

Code:
.forum_list .breadBoxTop {
display: none;
}

.forum_list .breadBoxBottom {
display: none;
}
but again not work with xenporta2.


Plz, what i can do?
My scenario was different than yours, but maybe this will help.

I had to hide breadcrumbs in a custom template because I'm also using a publically-visible list forum that was showing up in the breadcrumbs as Home > Articles > Articles. You need to identify the relevant template, which is probably the same one you edited out the forum title above. Look for <xen:breadcrumb> code segments.

Here's the code I used in my template:

Code:
<xen:comment>
<xen:navigation>
    <xen:breadcrumb source="$nodeBreadCrumbs" />
</xen:navigation>
</xen:comment>
Note that this might not work for your portal homepage. Also note that I'm not an expert and there may be different best practices. It might be standard to comment within <the navigation> tags. I got the results I wanted: Home > Articles

Just incase it helps other newbs like me, this was the basic conditional statement I was attempting, but gave up on before I realized I needed the H1 tags.

Code:
<xen:if is="{$contentTemplate} != 'EWRporta2_ArticleView'">    
Show breadcrumbs
<xen:elseif is="{$contentTemplate} != 'EWRporta2_ArticleList'">
Show breadcrumbs
<xen:else />
Hide breadcrumbs
</xen:if>
 

MySiteGuy

Formerly ftsservice
This does not import VB4 CMS. You can use https://xenforo.com/community/resources/th-vbulletin-4-cms-importer.2889/

You'll need to create article categories manually to match your VB4 categories, then move each article that import creates a thread for into the article section. If you're interested in hands off start to finish process without that plugin and the work involved moving articles, send me a Conversation Message.
 
Hi, im having som isuses with XenPorta on my XenForo.
Im using XenForo version xenforo2.0.12, and XenPorta2.0.2.5.

When I try to install the addon in XenForo I got a 403 page.
Look at the picture bellow:
 

OUTL4W

Active member
Hi, im having som isuses with XenPorta on my XenForo.
Im using XenForo version xenforo2.0.12, and XenPorta2.0.2.5.

When I try to install the addon in XenForo I got a 403 page.
Look at the picture bellow:
I think you want the version designed specifically for XF2



my query:
Is there a way to have the images alternate positions from left to right per article?
 
Top