[8WR] XenPorta (Portal) PRO

[8WR] XenPorta (Portal) PRO [Paid] 1.2.2b

No permission to buy ($40.00)

ak38

Active member
The plugin you linked me to only shows albums (this is why it's called album block), so now Ive got the pic of the first image uploaded to two albums. See here:
FreeCannabis.com

What i want is like the forum page:
https://freecannabis.com/forums/ showing random images on the top not albums.

I have no settings at all in this plugin we are discussing to set any categories only albums see settings, everything about it including the name is about albums, do you have a different plugin, please check for me as im desperate to get this working!
 

Attachments

  • Screenshot 2017-08-13 at 5.49.43 PM.png
    Screenshot 2017-08-13 at 5.49.43 PM.png
    467.4 KB · Views: 25

Redh

Active member
@ak38 - I am so sorry, I sent you that link as I had it bookmarked thinking it was the one I am using. However having looked into this again for you I think it is this one here:

https://xenforo.com/community/threads/8wr-xenporta-2-portal-pro-paid.89112/post-878274

It really should be added to the FAQ to make it easier to find, but I guess Jaxel sees it as a competing product to his own media gallery. Sorry for steering you the wrong way before - I hope this is the right one :(
 

ak38

Active member
Hi @Redh, that link didnt work for me I had alreadt exhausted everything before i posted, when i tried it i got blinking text and no images??

I've given up entirely on getting images on the portal.

but I guess Jaxel sees it as a competing product to his own media gallery
 

Chernabog

Well-known member
@Jaxel okay so I purchased XenPortal2 on the recommendation of WhiteSky from Nulumnia and I see where it says it has tons of widgets included, but I need help. It looks like this add on would benefit from an extensive user documentation.

It seems as though it should also be an articles system, but I do not see that ability with it.

So could someone please help me on how I can set this up properly as a homepage for my site (what route filter do I use?) - and how do I add in the feature of articles, etc?

Right now, I just purchased what I believe to be a very full featured extensive plug in from a add-on creator I trust, but I simply have NO IDEA how to implement it properly....

Any help is appreciated.
 

Ashley.S.

Active member
Hi @Jaxel my client is loving XenPorta 2. One problem though. If they put any widgets in the following section:

2017-08-20.png

as soon as you go mobile or responsive, the widget disappears and gets replaced with white space, any ideas what might cause this?

Thanks!
 

ak38

Active member
Hi Jaxel,

Quick question, when I make a thread an article and click Exclude from Article Index, the article still shows on the list of recent threads on the front page.

So I'm guessing the setting controls something else, though I'm not sure what.

I want to have articles but have those articles not show in the list of recent threads on my front page - how would I achieve this?

Thanks
 

ak38

Active member
Another issue when I enable
Enable Widget Framework - Article View

I get the article opening when clicked, then the list of recent threads on the same page, then the comments section
I need the comment box to be below the article and above the list of recent threads - how can I change this? It's weird having the comments box 2 pages down under recent threads.

Thanks
 

BelMa

Member
Recently switched from vB to XF using XenPorta, very happy with the results.

A XP customization question: is there a way to add "MarkAsRead" for registered users in the XP Home Sub-Tabs ? Our members are accustomed to this option...

Thans in advance.
 

snoopy5

Well-known member
@Drunken

please look first at all the videos the author uploaded. Everything for a proper setup is explained there in detail. It is also recommended to inform yourself before buying a plugin instead of buying it and complain afterwards that this is not what you wanted to have, because you did not inform yourself enough what this plugin is able to do ;)

@ak38

I do not see really your problem at the moment. As far as I understood, you are using Media gallery and Xenporta 2. You are looking now for a way to display on a random basis images that are located in one or more albums within your media gallery, right?

The place where these random images shall bis visible is not the forum index page, but the Xenporta page (i assume you use xenporta as the entry page of your forum).

I do not see an obligation for Jaxel to provide a widget for this. This should be the responsability of the author of the Media Gallery plugin. I do not own media gallery so I can not tell you whether they have that kind of widget already.

I use for example the sonnb gallery software plugin. And the author a feature to show images on the index page of the forum. Basically it is a feature of his gallery software. I do not know whether he also offers a functionality to show this on Xenporta 2. You have to ask him yourself. He is called sonnb.

@Redh

The links you are recomending are doing totally different things. The second one is for another plugin called showcase items. The first one is for xen Media gallery, but only to show albums. And the author of this script is providing the widget to be able to work with Xenporta 2.


XFMG Album Block lets you display a new block on your forum displaying either Latest or Random albums from your XenForo Media Gallery.

Block is displayed without needing widgets, but you can also display them using 2 widgets included:

Widget Framework
XenPorta 2 Pro


What do you mean exactly with this:

...but I guess Jaxel sees it as a competing product to his own media gallery....

What is in your view a competing product of Jaxel? Please post a link!
 

DarkGizmo

Well-known member
Jaxel, just recently returned to XF. How can I obtain the newest version of XenPorta 2? I have a license, where is the releases sent again?
 

kailew

Member
Hi @Jaxel,

since some weeks, I don't know exactly, I'm getting errors like this:

Code:
Server Error

Undefined index: thread_id

XenForo_Application::handlePhpError() in EWRporta2/ControllerPublic/Thread.php at line 11
EWRporta2_ControllerPublic_Thread->actionIndex() in RainDD/UserActivity/Controller/ThreadViewers.php at line 8
RainDD_UserActivity_Controller_ThreadViewers->actionIndex() in RainDD/UserActivity/Controller/ThreadReaders.php at line 8
RainDD_UserActivity_Controller_ThreadReaders->actionIndex() in Andy/SimilarThreads/ControllerPublic/Thread.php at line 12
Andy_SimilarThreads_ControllerPublic_Thread->actionIndex() in ChangeThreadStarter/ControllerPublic/Thread.php at line 7
ChangeThreadStarter_ControllerPublic_Thread->actionIndex() in HidePollResults/ControllerPublic/Thread.php at line 12
HidePollResults_ControllerPublic_Thread->actionIndex() in XenForo/FrontController.php at line 351
XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
XenForo_FrontController->run() in /kunden/portugalinks.de/xenforo/public_html/index.php at line 13

I've found, that these errors where caused by not working internal redirects. I don't use them very often, so the error was not very disturbing. But now ...

Today I've spent a little time on the problem and disabled all the plug-ins in the error massage one after another ... and disabling EWRPorta2 was the solution, the internal redirect was working ... any ideas?

Kai
 

kailew

Member
Because Brogan closed the thread https://xenforo.com/community/threads/internal-redirects-are-not-working.133872 I will continue here ... yes, it's not the last version, but 1.2.2 (and not 1.2.2b). I've passed the last one, because with the update before the lot of style-changes I've made with the slider were overwritten. It was the second time, that this happened, so I decided to wait until the next "big" one. @Jaxel, do you have any idea how I could avoid that my changes will be overwritten again? If this would work, I would do the update asap ... ;)

Kai
 

Jaxel

Well-known member
Because Brogan closed the thread https://xenforo.com/community/threads/internal-redirects-are-not-working.133872 I will continue here ... yes, it's not the last version, but 1.2.2 (and not 1.2.2b). I've passed the last one, because with the update before the lot of style-changes I've made with the slider were overwritten. It was the second time, that this happened, so I decided to wait until the next "big" one. @Jaxel, do you have any idea how I could avoid that my changes will be overwritten again? If this would work, I would do the update asap ... ;)

Kai
Lettered updates don't require you to run the upgrade script (thus, wont overwrite your templates)... only upload files.

Also, it looks like 1.2.2b's entire purpose is to put in protection for this specific error and to prevent clashes with other addons that don't conform.
 
Top