• This forum has been archived. New threads and replies may not be made. All add-ons/resources that are active should be migrated to the Resource Manager. See this thread for more information.

[8wayRun.Com] XenAtendo (Events)

Status
Not open for further replies.

DoctorWatsOn

Well-known member
Neither of these seem to be there/work if you've chosen the create a thread with this event option.

If I create an event without a thread yes, it works as you say. If you create a thread with the event it doesn't appear to.

Regards,
Renada :)
Here's an event with a thread - the edit option is displayed next to the event title on the right, just above the start & end dates.

Event.jpg

Does that help?
 

Renada

Active member
Here's an event with a thread - the edit option is displayed next to the event title on the right, just above the start & end dates.

View attachment 11692

Does that help?
Ummmm nope LOL! Ok I'm wondering if its because I don't use the map?

This is what I'm doing:
Go the the calendar
Select the event from the calendar - this opens up the thread in the events forum.
The thread views like a normal thread with normal thread options.

Have I got something set wrong somewhere?

Not creating a thread makes it work as you and Oracle say.

rsvp.PNG
 

Renada

Active member
Hmmm seems I must have something screwy somewhere because the map doesn't appear if I choose the post a thread option.

This is a fresh install of everything, forums and all Jaxel's add-ons.

Renada
 

Ryan Kent

Well-known member
You have hit upon Jaxel's favorite type of issue....permissions!

Go into your ACP, give yourself permissions to edit events, and you will be fine
 

Ryan Kent

Well-known member
Sec, let me do my Jaxel impersonation :eek: It's Permissions!!

XenAtendoPermissions.JPG

Check your admin and then check EVERY group the admin belongs to. On a clean XF install the admin is a member of Moderators and Registered Users groups. If you chose Never for either of those groups, or any group an admin belongs to, the Never will over-ride everything else. You should try to avoid assigning the Never permission as much as possible. If you do use it, make sure it's not on any permission group which also have Admins assigned to it.
 

Renada

Active member
Right now I'm the only person there - I have Admin as my main group and no other groups. All admin permissions are set to yes.

I can edit events and do everything I should be able to do EXCEPT when a thread is created. The map doesn't show up if I choose it and I don't get any edit options except the normal thread edit options.

Am going to uninstall and start again because it worked with the map before I started from scratch LOL!

Regards,
Renada
 

ddmmh

Well-known member
Right now I'm the only person there - I have Admin as my main group and no other groups. All admin permissions are set to yes.

I can edit events and do everything I should be able to do EXCEPT when a thread is created. The map doesn't show up if I choose it and I don't get any edit options except the normal thread edit options.

Am going to uninstall and start again because it worked with the map before I started from scratch LOL!

Regards,
Renada
Are you logged in as someone with the right permissions to edit? You should be able to just click the events tab and then 'edit' on the event you want to modify.
 

Renada

Active member
As I said, I have the right permissions or I wouldn't be able to edit events that don't create a thread. It's a fresh install of Xenforo RC3 and latest versions of the add-ons so I'm just going to redo it all and see if that fixes it.

Regards,
Renada
 

DoctorWatsOn

Well-known member
I've finally gone live with this add-on HERE and I've a couple of users copying over events from the old vB calendar and it seems to be coping well with the number of events...

Events_live.jpg Events_live_2.jpg

The only reported problem is an error message if the event title + town & postcode is over 100 characters, however it still posts the event, but not the associated thread – odd.

Does this mean that the add-on has no title limit, but xF does for thread titles?

EDIT: I started this thread, as I couldn't find an answer - Is there a character limit for thread titles? and then stumbled across this thread [Fixed] Limit thread title entry to 100 characters, both of which could be handy for anyone else having a problem with this.

It looks like xF limits thread titles to 100 characters and also prevents you from typing one longer, whereas that's not the case when adding an event, which is made worst because it [brilliantly] pulls in the town & postcode (or city, state, ZIP code) as part of the title.

Is this something that can be fixed, Jaxel?
 

Renada

Active member
Are you sure?

After installing this add-on, you need to check 'user group' permissions again, as 3 new permission levels appear at the bottom of the permissions list for XenAttendo.
Thanks to You, Oracle and ddmmh for trying to help on this :) It turned out to be a corrupted user and reinstalling everything again from scratch and not importing users from vb solved it :)

Regards,
Renada
 

Jaxel

Well-known member
doh! lol

What is the difference between "Can Moderate Events" and "Can Administrate Events" ?
A moderator can edit events... an administrator can edit stream services...

Preview of features in the next version...
Untitled-1.gif

You can now specify a constant stream page, which can be found:
http://www.8wayrun.com/stream/


And a preview to "[8wayRun.Com] XenHablas (IRC Chat)"
Untitled-2.gif

This new chat mod will integrate directly with XenAtendo (if you have it installed)...
example: http://www.8wayrun.com/chat/
You can click on the (SHOW STREAM) and (HIDE STREAM) buttons on the top right control.
 

Renada

Active member
Hi Jaxel,

Well I was wrong it wasn't a corrupted user problem. The problem seems to be XenMedia 1.25.

I have a fresh install of everything, clean database, only 1 user.

Xenforo RC3
XenPorta 1.27
XenAttendo 1.25
XenMedia 1.25

The portal and events work perfectly. Install XenMedia and the map no longer shows up in the Events threads, nor does the edit event button. Disabling XenMedia doesn't fix it - uninstalling it does.

Without XenMedia installed

Nomedia.PNG

With XenMedia installed

withmedia.PNG
Any ideas?

Regards,
Renada :)
 

Ryan Kent

Well-known member
I want to be helpful but I am not clear on the issue. In both of the pics you shared I see an edit button in the upper right corner, and a Google map. What is not working correctly?
 

Renada

Active member
I want to be helpful but I am not clear on the issue. In both of the pics you shared I see an edit button in the upper right corner, and a Google map. What is not working correctly?
You were too quick - look again LOL!

(the attachment loaded the same one twice)

Renada
 
Status
Not open for further replies.
Top