1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 1.4.4 to 1.4.6 problem?

Discussion in 'Installation, Upgrade, and Import Support' started by dieg0, Apr 11, 2015.

  1. dieg0

    dieg0 Active Member


    Yesterday I upgraded via the command-line my test forum from 1.4.3 to 1.4.6 and everything went smoothly. So this morning I did the same thing on my production forum which was on 1.4.4 at the moment of upgrade. However the "forum closed while being upgraded blah" message was still in place after I finished the process. After that I run run-upgrade.php again from the command line but same thing happened. Finally I tried the browser upgrade and it worked.

    I think everything is working as expected now (?) but I'd like to know what went wrong. Both production and testing forum have nearly the same number of posts and share the same dedicated server.

  2. Mike

    Mike XenForo Developer Staff Member

    If you have enabled caching in config.php that uses a system that won't be shared between the CLI and the web server (such as APC), XF will be reading from a stale cache. You'll need to finish the upgrade via the web to get the caches rebuilt.
  3. dieg0

    dieg0 Active Member

    Hi Mike,

    You may be right :) This is my config.

    So just to be clear do I need to turn enabled to false before every upgrade?

  4. Mike

    Mike XenForo Developer Staff Member

    No, that still won't write to the cache so the issue is that you have stale data in the cache. If you're doing the CLI upgrade, you need to clear the APC cache once you finish; or you should just do the regular web update.

Share This Page