XF 1.5 Upgrading 1.5.4 to 1.5.11 problem

#1
Hey,

I prepared my upgrade as usual:
- I turn off forum,
- I disabled all plugins,
- I made forum files backup,
- I made db backup dump,
- I downloaded upgrade packed,
- I uploaded it to server and merged with existing installation,
- I logged to admin and performed upgrade.

And as usual everything went smoothly and worked correctly. I had 1.5.11 working forum. I should made another backup at this point... but I didn't.
Than I started updating plugins, and I made boo boo - I replaced library folder from plugin, which lead to deleting all forum files that are necessary to run forum :D

So, I uploaded them again from 1.5.11 upgrade package. But still some things were missing. So I though - hell with that, lest's recover from backup and do upgrade again. And I did:
- I cleared database and imported db 1.5.4 backup,
- I deleted all forum files and copied 1.5.4 backup,
- Forum runs nicely at 1.5.4, everything works.
- I uploaded and merged 1.5.11 upgrade,
- I went to admin CP I pressed start upgrade,
- And... "You have already completed installation. If you wish to reinstall, please delete the file internal_data/install-lock.php."

I tried couple things, deleted all sessions, cookies, I checked DB XF options and upgrade tables. Everything looks ok, like a 1.5.4 before upgrade. But still, I cannot upgrade to 1.5.11 now.

Any ideas? I read https://xenforo.com/community/threads/you-have-already-completed-installation.87655/ but it doesn't help, beside making point of merging directories when uploading :)
 

Chris D

XenForo developer
Staff member
#2
According to the version that is displayed when I visit your install page, you still don't have the 1.5.11 files in place.
 
#5
Not really Brogan. As I explained in first post, every another attempt produce same error.
You have already completed installation. If you wish to reinstall, please delete the file internal_data/install-lock.php.

:(
 

Brogan

XenForo moderator
Staff member
#6
Typically there are two causes of that - the files have not been uploaded correctly, or server caching is preventing the new files from being served.

Contact your host regarding the caching if you are sure the files are in the correct location.
 

Mike

XenForo developer
Staff member
#7
Or go to <url>/install/index.php?upgrade/ directly. If you're in the install section, then refreshing that won't change and it's possible the redirect from the basic URL has been cached. (Though if you were in a situation that caused you to be redirected there in the first place, that would generally indicate an issue with a process used as it would only happen if specific files were removed.)
 
Top