AMPXF - AMP for Xenforo 2

AMPXF - AMP for Xenforo 2 1.4.8 Patch Level 3

No permission to buy (€50.00)
  • Fix "share icon" for posts
  • Compatibility with AL/OriginalPosterHighlight
  • Compatibility with EWR/Medio
    • Also cleans away some broken markup border="0" which is not okay with HTML5 markups
  • Redirect ?amp=1 on forums/subforums to the canonical page since those are not AMP:ed (yet)
  • Fix favicon background issue for XenBase theme
  • Cleaned up the option descriptions a bit.
  • Added link to FAQ about JSON-LD
  • Added option to disable AMP for threads started by specific users
    • This will allow compatibility with e.g. "commen threads" created by @Mangini's XFtoWP addon
Note: This release will likely require a "merge template" after install. Especially if you have added custom modifications to amp_style_custom.less
  • Rename amp_style_custom.less to amp_extra.less to be more aligned with extra.less-naming
    • You should copy over your custom changes from amp_style_custom.less to the new amp_extra.less
  • "Block-level" ad positions to also have the class block-container-ad on them so they can be styled
    • Default styling (in amp_extra.less) also that sets:
      • transparent background
      • no border
      • center the ad (in case it is not full-width/responsive)
  • Moved <amp-analytics> code into own template amp_analytics for better separation and easier management of custom code there (less template conflicts)
  • AMPBot won't complain about logo width/height not being set when using a text logo
  • Extend XFRM & XFMG correctly with the XFCP_-system so it works with other addons that also extend their functionality.
Fixes the ErrorException: [E_NOTICE] Undefined index: isAMP error
  • Option for showing Text logo instead of Image logo
  • Style properties for Text logo
  • Fixed class extension to be done correctly
    • This should fix the Call to undefined method MaZ\AMP\XF\Template\Templater22::foo() errors some have experienced
  • Fix to always expose the $isAMP variable to templates and macros
AddonFlare apparently sets a really high "Execution order" on their addons (999999999) which seems to have problems with the Templater not finding functions in their addons when ours is installed.
Fix so that the AMP options ganalytics id overrides the "default" XF set option. (Previously only set if XF one was empty and AMP one set)
  • Like
Reactions: Sunka
  • Fix embed for JSFiddle
  • Refactored code a bit
  • Fix "members online" pixel for RMS/Showcase when viewing "reviews"
  • Fix compatibility with forums that don't have useFriendlyUrls enabled
Top