• This forum has been archived. New threads and replies may not be made. All add-ons/resources that are active should be migrated to the Resource Manager. See this thread for more information.

[XFR] Merge Double User Post

Pepelac

Well-known member
Also, I don't understand the above - isn't it supposed to rewrite the contents?
Sorry, I've used a wrong word. Should be "replace" instead of "rewrite". It means, that if I'll upload the library folder, that ftp client will replace contents of the library folder with the new one from the local computer. By replacing I mean, that it'll delete all contents from the server and will add only that content, that will be in the soem folder on the local machine...
 

Jo.

Well-known member
Sorry, I've used a wrong word. Should be "replace" instead of "rewrite". It means, that if I'll upload the library folder, that ftp client will replace contents of the library folder with the new one from the local computer. By replacing I mean, that it'll delete all contents from the server and will add only that content, that will be in the soem folder on the local machine...
Ahh thanks for that. :) I understand now. :)
 
I'm having issues with the [MERGETIME] tag showing up instead of the timestamp spacer. I've got "Use Timestamp Spacer" checked, I've got "Replace [MERGETIME] Tag" set, with the Timestamp spacer option as well. Still getting [MERGETIME] though.
 
Still having issues with [MERGETIME]. Had to shut off the timestamp spacer to make it go away.

Also, posts made from an iPad do not get merged. The first post is simply replaced. Going to uninstall this add-on, as it is clearly broken.
 

trilogy33

Well-known member
When clicking Members Online Now in the sidebar, sometimes this error occurs with a white screen:
Fatal error: Class 'XFCP_XfRu_MergeDoubleUserPost_ControllerPublic_Thread' not found in /home/domain/public_html/community/library/XfRu/MergeDoubleUserPost/ControllerPublic/Thread.php on line 213
 

trilogy33

Well-known member
Above error became permanently obsessive earlier today so...
Update and FWIW, "Seem" to have cured this by uninstalling/reinstalling.
 

Pepelac

Well-known member
When clicking Members Online Now in the sidebar, sometimes this error occurs with a white screen:
Fatal error: Class 'XFCP_XfRu_MergeDoubleUserPost_ControllerPublic_Thread' not found in/home/domain/public_html/community/library/XfRu/MergeDoubleUserPost/ControllerPublic/Thread.phpon line213
Know about that, try to fix ASAP
 

trilogy33

Well-known member

When clicking Members Online Now in the sidebar, sometimes this error occurs with a white screen:
Fatal error: Class 'XFCP_XfRu_MergeDoubleUserPost_ControllerPublic_Thread' not found in /home/domain/public_html/community/library/XfRu/MergeDoubleUserPost/ControllerPublic/Thread.php on line 213
Above error became permanently obsessive earlier today so...
Update and FWIW, "Seem" to have cured this by uninstalling/reinstalling.
Aha! Just found an easier way of working around this other than uninstalling / reinstalling. Well it's just this second worked a treat for me.
Go into the options and simply drop the Check Interval to Zero, save it and then check the Members Online Now page is ok. Then return the Check Interval back to the original figure you had.
Note: Disabling the modification does not cure it entirely, neither does the above Check Interval method...it simply returns the Members Online Now page back to operation.
Not sure why it seizes up sometimes or what triggers it.
 

trilogy33

Well-known member
Is this fixed?
Which part?
If you mean my error:
When clicking Members Online Now in the sidebar, sometimes this error occurs with a white screen:
Fatal error: Class 'XFCP_XfRu_MergeDoubleUserPost_ControllerPublic_Thread' not found in/home/domain/public_html/community/library/XfRu/MergeDoubleUserPost/ControllerPublic/Thread.phpon line213
I've had no issues lately and even so, it's very easily fixed...
Aha! Just found an easier way of working around this other than uninstalling / reinstalling. Well it's just this second worked a treat for me.
Go into the options and simply drop the Check Interval to Zero, save it and then check the Members Online Now page is ok. Then return the Check Interval back to the original figure you had.
Note: Disabling the modification does not cure it entirely, neither does the above Check Interval method...it simply returns the Members Online Now page back to operation.
Not sure why it seizes up sometimes or what triggers it.
 

ArucarD

Member
I want to install this, I truly do. But I am uncertain due to the errors being reported. :-/ I need this as well, definitely helps to keep someone from going insane on a forum or spamming a topic.
 

cynthetiq

Active member
I'm getting this error. I figure it's because of this mod only because I see the atoload XfRu_MergeDoubl...'

Code:
XenForo_Exception: Cannot load class using XFCP. Load the class using the correct loader first. - library/XenForo/Autoloader.php:108
Generated By: xxx_xxx, Today at 12:03 PM
Stack Trace
#0 [internal function]: XenForo_Autoloader->autoload('XFCP_XfRu_Merge...')
#1 /www/thetfp.com/library/XfRu/MergeDoubleUserPost/ControllerPublic/Thread.php(15): spl_autoload_call('XFCP_XfRu_Merge...')
#2 /www/thetfp.com/library/XenForo/Autoloader.php(119): include('/www/thetfp.com...')
#3 /www/thetfp.com/library/XenForo/Application.php(852): XenForo_Autoloader->autoload('XfRu_MergeDoubl...')
#4 /www/thetfp.com/library/XenForo/Model/Session.php(303): XenForo_Application::autoload('XfRu_MergeDoubl...')
#5 /www/thetfp.com/library/XenForo/ControllerPublic/Online.php(50): XenForo_Model_Session->addSessionActivityDetailsToList(Array)
#6 /www/thetfp.com/library/XenForo/FrontController.php(310): XenForo_ControllerPublic_Online->actionIndex()
#7 /www/thetfp.com/library/XenForo/FrontController.php(132): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#8 /www/thetfp.com/index.php(13): XenForo_FrontController->run()
#9 {main}
Request State
array(3) {
  ["url"] => string(29) "http://www.thetfp.com/online/"
  ["_GET"] => array(0) {
  }
  ["_POST"] => array(0) {
  }
 

cynthetiq

Active member
so here's what I get when I do the current users online. I reinstalled that didn't work.

I can't find the check interval anywhere, what part of options are you referring to?

Code:
Server Error

Cannot load class using XFCP. Load the class using the correct loader first.

XenForo_Autoloader->autoload()
spl_autoload_call() in XfRu/MergeDoubleUserPost/ControllerPublic/Thread.php at line 15
include() in XenForo/Autoloader.php at line 119
XenForo_Autoloader->autoload() in XenForo/Application.php at line 852
XenForo_Application::autoload() in XenForo/Model/Session.php at line 303
XenForo_Model_Session->addSessionActivityDetailsToList() in XenForo/ControllerPublic/Online.php at line 50
XenForo_ControllerPublic_Online->actionIndex() in XenForo/FrontController.php at line 310
XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132
XenForo_FrontController->run() in /www/thetfp.com/index.php at line 13
This happens when I got to current users and press the page 2 button. It does not happen on page one.
 

Paul

Well-known member
Hi pepelac,

Is there a way that i can remove.disable the "last message in the thread belongs to the same user" condition?

Reason is this

I have a forum that currently isnt working properly, so therefore using an RSS feed. Therefore i tend to get the following:

grab.jpg

Now ideally i'd like to be able to merge the two identical threads (unfortunately there is not a "Re:" in the first thread - do the titles need to be identical???? it's always the same prefix every time...

Cheers
Paul
 
Top