XF2 [8WR] XenPorta 2 (Portal) PRO

XF2 [8WR] XenPorta 2 (Portal) PRO [Paid] 2.2.0.7

No permission to buy ($40.00)

rtr2006

Active member
I bought this add-on. It looks to be great for what I am wanting. But I am struggling to even get it set up. I have it installed and I have all of the options. I watched the two youtube videos, but I feel like that's starting from something that's already there. How do you start this from scratch?

http://www.bamanation.net/
 

Frode789

Well-known member
I bought this add-on. It looks to be great for what I am wanting. But I am struggling to even get it set up. I have it installed and I have all of the options. I watched the two youtube videos, but I feel like that's starting from something that's already there. How do you start this from scratch?

http://www.bamanation.net/

Promote threads is first, click on threads, then the "..." icon to edit it, and select "promote to article". It is in the drop down menu. Then they will appear (as long as the user group has permissions to see the articles) on the home page.

After that, you can start populating your home page with widgets. Xenforo uses the default widget system, it is in ACP under Appearance. Then simply select the widgets you want, and chose what position they should appear in.

As for the feature slider, super easy. Just promote a thread to feature instead of articles (or you can do both), and they will appear in the slider.
 

VanillaNeko

Active member
Good evening, Jaxel,

I wanted to know, how is it going for the Xenforo 1 license holders?

Thank you in advance for your answer.
 

marring

Member
I got the error while upgrade by import from previous version.

Code:
InvalidArgumentException: Attempted to convert NULL to string/binary [feature_media] in src/XF/Mvc/Entity/Entity.php at line 685
XF\Mvc\Entity\Entity->_castValueToType() insrc/XF/Mvc/Entity/Entity.php at line 572
XF\Mvc\Entity\Entity->set() in src/XF/Mvc/Entity/Entity.php at line 671
XF\Mvc\Entity\Entity->bulkSet() insrc/addons/EWR/Porta/Import/Importer/Porta121.php at line 168
EWR\Porta\Import\Importer\Porta121->stepFeatures() insrc/XF/Import/Runner.php at line 160
XF\Import\Runner->runStep() in src/XF/Import/Runner.php at line 74
XF\Import\Runner->run() in src/XF/Admin/Controller/Import.php at line231
XF\Admin\Controller\Import->actionRun() in src/XF/Mvc/Dispatcher.phpat line 249
XF\Mvc\Dispatcher->dispatchClass() in src/XF/Mvc/Dispatcher.php at line 87
XF\Mvc\Dispatcher->dispatchLoop() in src/XF/Mvc/Dispatcher.php at line 41
XF\Mvc\Dispatcher->run() in src/XF/App.php at line 1880
XF\App->run() in src/XF.php at line 328
XF::runApp() in admin.php at line 13
 

Jake B.

Well-known member
Screen Shot 2018-01-24 at 8.35.09 AM.png

At least Papyrus isn't being used now, but instead of using a weird font that isn't used anywhere else and is being explicitly loaded for just these titles it may be best to just use whatever font the style is using :p
 

rtr2006

Active member
I've made progress. But now how do I get the articles to feature. I did try to click the ... but when I put it to an article it doesn't appear anywhere.

1516807544149.png
 

Jaxel

Well-known member
I got the error while upgrade by import from previous version.

Code:
InvalidArgumentException: Attempted to convert NULL to string/binary [feature_media] in src/XF/Mvc/Entity/Entity.php at line 685
XF\Mvc\Entity\Entity->_castValueToType() insrc/XF/Mvc/Entity/Entity.php at line 572
XF\Mvc\Entity\Entity->set() in src/XF/Mvc/Entity/Entity.php at line 671
XF\Mvc\Entity\Entity->bulkSet() insrc/addons/EWR/Porta/Import/Importer/Porta121.php at line 168
EWR\Porta\Import\Importer\Porta121->stepFeatures() insrc/XF/Import/Runner.php at line 160
XF\Import\Runner->runStep() in src/XF/Import/Runner.php at line 74
XF\Import\Runner->run() in src/XF/Admin/Controller/Import.php at line231
XF\Admin\Controller\Import->actionRun() in src/XF/Mvc/Dispatcher.phpat line 249
XF\Mvc\Dispatcher->dispatchClass() in src/XF/Mvc/Dispatcher.php at line 87
XF\Mvc\Dispatcher->dispatchLoop() in src/XF/Mvc/Dispatcher.php at line 41
XF\Mvc\Dispatcher->run() in src/XF/App.php at line 1880
XF\App->run() in src/XF.php at line 328
XF::runApp() in admin.php at line 13
What version are you upgrading from? You need at least XenPorta 1.2.1 to upgrade.
 

rtr2006

Active member
Read the FAQ...

Why do I even made this FAQ and these videos if no one looks at them.

I did watch the videos, but again, I felt like I was starting from scratch and you already had something built. Thank you for your great support btw..

So I made the change and now I see the featured and an article, but no forums, or widgets, below.
 

BigPete7978

Active member
Read the FAQ...

Why do I even made this FAQ and these videos if no one looks at them.
I have read the FAQ and watched the vids. They were helpful, but I still have yet to be answered on whether or not I have to purchase the copyright removal again with this add on or did it carry over from the XF1 add on like the free version did to the paid version.
 
Top