1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed Xenforo 1.2 to Xenforo 1.2 Importer Error

Discussion in 'Resolved Bug Reports' started by DRE, Aug 3, 2013.

  1. DRE

    DRE Well-Known Member

    Importing my site to a test board. Ran into some errors.

    First error due to this addon: http://xenforo.com/community/resources/join-user-group-by-waindigo.225/
    Import User Groups.

    • The field 'joinable' was not recognised.
    • The field 'joinable_moderated' was not recognised.
    • The field 'description' was not recognised.
    • The field 'joinable_moderator_user_ids' was not recognised.
    I uninstalled it and tried again.

    Import User Groups
    Imported 7 items. (0.01 seconds)

    Import Custom User Fields
    Imported 55 items. (4.08 seconds)

    Import Users

    Server Error
    copy(/home/me/public_html//avatars/l/0/3.jpg): failed to open stream: No such file or directory

    1. XenForo_Application::handlePhpError()
    2. copy() in XenForo/Importer/XenForo.php at line 772
    3. XenForo_Importer_XenForo->_importUser() in XenForo/Importer/XenForo.php at line 599
    4. XenForo_Importer_XenForo->_importOrMergeUser() in XenForo/Importer/XenForo.php at line 353
    5. XenForo_Importer_XenForo->stepUsers() in XenForo/Importer/Abstract.php at line 77
    6. XenForo_Importer_Abstract->runStep() in XenForo/ControllerAdmin/Import.php at line 180
    7. XenForo_ControllerAdmin_Import->_runStep() in XenForo/ControllerAdmin/Import.php at line 232
    8. XenForo_ControllerAdmin_Import->_startStep() in XenForo/ControllerAdmin/Import.php at line 175
    9. XenForo_ControllerAdmin_Import->actionStartStep() in XenForo/FrontController.php at line 337
    10. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
    11. XenForo_FrontController->run() in /home/me/public_html/test/admin.php at line 13
  2. Mike

    Mike XenForo Developer Staff Member

    Going to move to bugs so we can look into this.

    The first one error shouldn't happen.

    The second error should be suppressed but it's because the data directory path wasn't entered correctly.
  3. DRE

    DRE Well-Known Member

    Was using



    is it because I forgot to add a backslash?

  4. Mike

    Mike XenForo Developer Staff Member

    Your data directory is /home/dre/public_html/data/ based on your internal_data value.
    DRE likes this.
  5. DRE

    DRE Well-Known Member

    Does this look right? Talking bout internal data path.

    Screen Shot 2013-08-03 at 2.31.12 PM.png
  6. Mike

    Mike XenForo Developer Staff Member

    No, your data directory is the data directory within your XF install, internal data is the internal_data directory (or where ever they're been put, if moved).
  7. DRE

    DRE Well-Known Member

    oh doh. I see what I did wrong. My bad.
  8. DRE

    DRE Well-Known Member

    I accidentally imported the same database I'm importing too.

    At least that works. :LOL:

    Screen Shot 2013-08-03 at 2.47.47 PM.png
  9. DRE

    DRE Well-Known Member

    All User Groups, Custom User Fields and Users were imported. It did that really fast.

    I'd say.. less than a minute for all three of those.

    It is stuck at User Following and Ignore Lists. It's been at 3.50% for the past 6 minutes.
  10. DRE

    DRE Well-Known Member

    There doesn't seem to be an order in which it imports user ids.

    I wish it would import user ids by join date.
  11. Jeremy

    Jeremy XenForo Moderator Staff Member

    It imports users based on user_id, which, should be join date.
  12. DRE

    DRE Well-Known Member

    Since its been stuck on importing User Following and Ignore Lists at 3.50% for the past 30 minutes can I go back a page and import something else?
  13. DRE

    DRE Well-Known Member

    And it did actually import followers etc. Don't know why its stuck there still.
  14. DRE

    DRE Well-Known Member

    After skipping Import User Following and Ignore Lists, Import Personal Conversations and Import Profile Posts I tried to Import Nodes. When I click on Import Nodes it leads me back to the Import External Data Import list. Everything after that is faded out except for Import User Upgrades. Speaking of Import User Upgrades, I did that and it worked (even though I had no upgrades). Import User Following and Ignore Lists is still stuck at 3.50% which tells me this may actually all be related to deleted users.
  15. DRE

    DRE Well-Known Member

    A full import doesn't work if you have posts, conversations and profile posts from deleted users.
    tafreehm likes this.
  16. Brogan

    Brogan XenForo Moderator Staff Member

    There's reason why it is labelled as Beta @DRE.
    Adam Howard likes this.
  17. Jon W

    Jon W Well-Known Member

    This is only an error because you must have had the Join User Group add-on installed on one site and not on the other. If you install it on both it should work fine.
    Last edited: Aug 5, 2013
    tyteen4a03 likes this.
  18. Mike

    Mike XenForo Developer Staff Member

    I have fixed both of the errors in the initial post.
    DRE and Jon W like this.
  19. DRE

    DRE Well-Known Member

    I'm really looking forward to this, thank you!

Share This Page