1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Implemented Warn on first post deletion

Discussion in 'Closed Suggestions' started by nodle, Aug 19, 2015.

  1. nodle

    nodle Well-Known Member

    So I just deleted a major sticky thread on a forum of mine trying to clean it up. I had no clue it would delete the entire thread!:eek: There should really be an additional statement that pops up letting you know that deleting the first post will permanently delete the entire thread. I just figured it would delete the post and not the entire thread. There should be an additional warning for something this severe. Or make it give a different warning. Now my thread made in 2006 with tons of posts is lost.:cry:
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    It is already stated.

    upload_2015-8-19_17-23-40.png
     
  3. nodle

    nodle Well-Known Member

    It didn't pop up for me then, I have 4 other posts selected at the same time, does this have something to do with it because it was multiple?
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

    There is a different but similar message when multiple posts are selected.

    upload_2015-8-19_17-26-0.png
     
  5. nodle

    nodle Well-Known Member

    No way to get it back without a forum backup then and restore? Maybe I just clicked to fast.
     
  6. Brogan

    Brogan XenForo Moderator Staff Member

    You will need to restore from a backup.

    It may be a good idea to remove the hard delete permission too.
    Soft deleted threads can be restored.
     
  7. nodle

    nodle Well-Known Member

    Thanks Brogan for the info.
     
  8. nodle

    nodle Well-Known Member

    Do you know which permission I would un check for myself (admin), and be able to set it to only soft deletes so that this doesn't happen by accident again? Is there anyway to stop myself and only switch to soft deletes being an admin?
     
  9. Brogan

    Brogan XenForo Moderator Staff Member

    There are separate permissions for hard deleting posts and threads.

    Set it to Not Set (No) for the user group(s).
     
  10. nodle

    nodle Well-Known Member

    Ok thank you @Brogan . I see the two separate ones listed. I changed the thread one, that should stop me. I really appreciate your help sir.
     
  11. nodle

    nodle Well-Known Member

    Is this the correct one, because I just tested it on an older thread and was still able to delete it.

    1.jpg
     
  12. Brogan

    Brogan XenForo Moderator Staff Member

  13. nodle

    nodle Well-Known Member

    This is mine for administrator group permissions, I haven't touched anything.

    2.jpg
     
  14. Brogan

    Brogan XenForo Moderator Staff Member

    Use the analyse permissions function.
    It is likely set via another user group.
     
  15. nodle

    nodle Well-Known Member

    I think this is it then.

    3.jpg

    Why is my user set with special permissions? I am the only person listed with special permissions. Is this normal?
     
  16. Brogan

    Brogan XenForo Moderator Staff Member

    You have likely set them yourself or it is from an import.

    Simply revert the custom permissions.
     
  17. nodle

    nodle Well-Known Member

    Must be from the import I did years ago, is there an option to revert I don't see any options for that. Sorry for all the questions.

    5.jpg
     
  18. nodle

    nodle Well-Known Member

    When I go in there i see this:

    6.jpg
     
  19. Jake B.

    Jake B. Well-Known Member

    At the very top by "Quick check all" click the gray "Not Set (no)" then save :)
     
    nodle likes this.
  20. nodle

    nodle Well-Known Member

    That did it Thanks to you both! @Jake B. and @Brogan
     

Share This Page