1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed Video Thumbnail Issue

Discussion in 'Media Gallery Resolved Bugs' started by Joe Link, Aug 9, 2016.

  1. Joe Link

    Joe Link Well-Known Member

    Trying to get video thumbnails and transcoding to work, starting with the thumbnails. I have FFMPEG binaries setup with the appropriate directories and permissions, version N-81300-gce2217b-static. I've tried from an iPhone 5 and a Moto G without success.

    I figured I'd try uploading one of the videos here, and it seems I and others are having the same isue: https://xenforo.com/community/media/categories/test-videos.4/

    Any ideas? I'm sure if it's not working here it won't work for me :)
     
  2. Chris D

    Chris D XenForo Developer Staff Member

    We don't have thumbnail creation enabled here, but local tests are showing that it's working fine.

    I'm using the latest FFmpeg (3.1.1) and the latest XFMG.

    Incidentally, I downloaded the video that you uploaded here, and tried it locally, and it wouldn't generate a thumbnail from that, so it could be the video that's at fault in this specific case.

    If you download this small video, and try to upload it on your own Gallery, hopefully the thumbnail will generate for you, like it does for me:

    upload_2016-8-9_20-20-39.png

    https://xenforo.com/community/media/css.1050/download

    Other things to check, are to double check the FFmpeg path is specified correctly and also ensure thumbnail creation is actually switched on:

    upload_2016-8-9_20-23-0.png
     
    Joe Link likes this.
  3. Joe Link

    Joe Link Well-Known Member

    Ah that makes a lot more sense :D

    I tried with the video you provided (painfully accurate, btw!) and it worked fine. Any idea why it might not work on videos uploaded via mobile devices (both Android and iOS), and what we might do to overcome that?
     
  4. Chris D

    Chris D XenForo Developer Staff Member

    Ah, well interestingly I just did a test from my own phone with a few videos. One worked, one didn't. One was short, one was longer. The short one didn't work.

    This led me to look into the code that was generating the thumbnail and I found a bug. Thumbnails weren't being created for videos shorter than 10 seconds, so that somewhat explains it :)

    So we'll fix this in the next release. In the meantime, if necessary, you can add a thumbnail manually. After the next release, you can rebuild thumbnails and this will generate any thumbnails that have been missing.

    Thanks for reporting this :)
     
    Joe Link likes this.
  5. Joe Link

    Joe Link Well-Known Member

    Hey alright! Good to hear it wasn't just me :D

    Thanks again for the excellent support Chris.
     

Share This Page