1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed Users with IP

Discussion in 'Resolved Bug Reports' started by Lucas, Nov 19, 2010.

  1. Lucas

    Lucas Well-Known Member

    It has been happening on all my XF installations online, and also to a friend. What does it mean? I've searched online with no accurate answer.

    Puntocom likes this.
  2. Puntocom

    Puntocom Well-Known Member

    It also happens in my forums
  3. jonsidneyb

    jonsidneyb Well-Known Member -
    NetHandle: NET-127-0-0-0-1
    NetType: IANA Special Use
    Comment: This block is assigned for use as the Internet
    Comment: host loopback address. Datagrams sent to
    Comment: addresses anywhere within this block loops back
    Comment: inside the host. Many implementation only
    Comment: support this for This block was
    Comment: assigned by the IETF in the Standard document,
    Comment: RFC 1122 and is further documented in the Best
    Comment: Current Practice document RFC 5735. These
    Comment: documents can be found at:
    Comment: http://www.rfc-editor.org/rfc/rfc1122.txt
    Comment: http://www.rfc-editor.org/rfc/rfc5735.txt
  4. jonsidneyb

    jonsidneyb Well-Known Member

  5. Lucas

    Lucas Well-Known Member

    I've seen information about the IP, my concern is why is it showing up as users browsing the forum. As it seems some of those are legit users.
  6. mjp

    mjp Well-Known Member

    Maybe xF defaults to that private IP if it can't determine the IP from the connection. But it isn't possible to get a connection from the internet on that IP. It's either coming from the local network your server is on ("Get out now! We traced the calls and they are coming from inside the house!"), or it's just a placeholder.
  7. Blandt

    Blandt Well-Known Member

    Big Brother :D
    Dean likes this.
  8. Mike

    Mike XenForo Developer Staff Member

    It's not coming out as unsigned. We will have to investigate.
  9. Mike

    Mike XenForo Developer Staff Member

    If you're having this problem, do you know if you're running a 64-bit operating system?
  10. Floris

    Floris Guest

    No, I get this on all the guests on xenfans.com - 32bit ubuntu lts 8.x server.
  11. Lucas

    Lucas Well-Known Member

    Nope, running CENTOS 5.5 i686.
  12. Kaiser

    Kaiser Well-Known Member

    You gott to be kidding, it visits my forum everyday... and i check the ips alot its so easy to remember. but i thought it is a spider or something

    EDIT: Its actually on my forum right now

  13. Lucas

    Lucas Well-Known Member

    Nothing on this?
  14. Mike

    Mike XenForo Developer Staff Member

    Sorry, thank you for the bump. Moving this to bug reports.
    Lucas and Puntocom like this.
  15. Decent60

    Decent60 Well-Known Member

    Dunno if you have access to this, but have you checked your raw access logs (or something similar). I used to own a server that, for some odd reason, 2 or 3 servers on the same network always did a scan of my site/server. We contacted the company and they said it was normal as it was one of their servers doing it (besides DNS, not sure why; there was no remote reboot option on that server). Each of those servers would scan my server at least 15x a day. Just a thought.
  16. Cezz

    Cezz Well-Known Member

    Is xenforo somehow tracking Apache internal dummy connections? They will show normally as on servers with IPv6 but as the whole 127 range is reserved I guess I understand it showing as
  17. Mike

    Mike XenForo Developer Staff Member

    After thinking the issue was more fundamental, with Floris's help I was able to eliminate various server things, and then I realized that it was only happening with guests because of a integer filter on input. So fixed for the next release. :)
    Puntocom likes this.
  18. Floris

    Floris Guest

    glad i could help. heeh
  19. Bas Kuis

    Bas Kuis New Member

    I ran into this problem some time ago.

    It turns out that when you use a int data type on a mysql table to store the iptolong value (integer representation of the ip address) the int datatype cannot contain all generated values. The numbers can be too large to be stored as a int.

    The maximum int value will convert back into the ip address.

    Solution: change the datatype of the mysql field to a varchar - or float (I think 10 characters should do it - but not sure ... 12 will do for sure)

Share This Page