1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 User Upgrades - Changing Back to Standart User Group and Back

Discussion in 'Troubleshooting and Problems' started by yavuz, Oct 16, 2013.

  1. yavuz

    yavuz Well-Known Member

    Hi,

    There are two user groups on my forum that a member can upgrade to given their activity. I've set up user groups looking up this suggestion here. So the secondary user group is where the user is added.

    Right now, when the user meets certain requirements he is added to user group A. And when he meets another threshold he is added to user group B. And when I look up the user setting page he is added to user group A and user group B.

    Theoretically, that shouldn't be a problem since I've set the "Display Styling Priority" but what happens is the users rank rolls back to default and after a while jumps between A and B and again back to default user group :)

    I don't know why this is happening, I believe my setting are correct.
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    I have the same method implemented on my forum and don't encounter that issue.

    All I can suggest is disabling all add-ons and then testing to determine which one is causing it.
     
  3. yavuz

    yavuz Well-Known Member

    While trying to debug it I got this error when I manually ran the user upgrades (crons):

    ErrorException: Argument 1 passed to WidgetFramework_Template_Trojan::WidgetFramework_setPageContainer() must be an instance of XenForo_Template_Public, instance of XenForo_Template_Admin given, called in /home/user/public_html/library/WidgetFramework/Listener.php on line 76 and defined - library/WidgetFramework/Template/Trojan.php:9
    Generated By: user, 46 minutes ago

    #0 /home/user/public_html/library/WidgetFramework/Template/Trojan.php(9): XenForo_Application::handlePhpError(4096, 'Argument 1 pass...', '/home/user/pu...', 9, Array)
    #1 /home/user/public_html/library/WidgetFramework/Listener.php(76): WidgetFramework_Template_Trojan::WidgetFramework_setPageContainer(Object(XenForo_Template_Admin))
    #2 [internal function]: WidgetFramework_Listener::template_create('PAGE_CONTAINER', Array, Object(XenForo_Template_Admin))
    #3 /home/user/public_html/library/XenForo/CodeEvent.php(58): call_user_func_array(Array, Array)
    #4 /home/user/public_html/library/XenForo/Template/Abstract.php(82): XenForo_CodeEvent::fire('template_create', Array, 'PAGE_CONTAINER')
    #5 /home/user/public_html/library/XenForo/Dependencies/Admin.php(154): XenForo_Template_Abstract->__construct('PAGE_CONTAINER', Array)
    #6 /home/user/public_html/library/XenForo/ViewRenderer/Abstract.php(263): XenForo_Dependencies_Admin->createTemplateObject('PAGE_CONTAINER', Array)
    #7 /home/user/public_html/library/XenForo/ViewRenderer/HtmlAdmin.php(135): XenForo_ViewRenderer_Abstract->createTemplateObject('PAGE_CONTAINER', Array)
    #8 /home/user/public_html/library/XenForo/FrontController.php(604): XenForo_ViewRenderer_HtmlAdmin->renderContainer('Zamanlay??c?? b...', Array)
    #9 /home/user/public_html/library/XenForo/FrontController.php(158): XenForo_FrontController->renderView(Object(XenForo_ControllerResponse_Message), Object(XenForo_ViewRenderer_HtmlAdmin), Array)
    #10 /home/user/public_html/admin.php(13): XenForo_FrontController->run()
    #11 {main}

    Request State

    array(3) {
    ["url"] => string(127) "http://www.site.net/admin.php?cron/...8392,87ef8457b5b8115cba310af4bfd919e53dac3c84"
    ["_GET"] => array(2) {
    ["cron/userGroupPromotions/run"] => string(0) ""
    ["_xfToken"] => string(53) "1,1381928392,87ef8457b5b8115cba310af4bfd919e53dac3c84"
    }
    ["_POST"] => array(0) {
    }
    }

    This happens for a long time, just didn't give too much thought until now.
     
  4. Tracy Perry

    Tracy Perry Well-Known Member

    Just an off-the wall question... you are running the latest version of that add-on, correct?
     
  5. yavuz

    yavuz Well-Known Member

    It's showing the [bd] Widget Framework 2.4.2 version.
     

Share This Page