1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 User tagging alerts not working

Discussion in 'XenForo Questions and Support' started by Solari, Nov 27, 2013.

  1. Solari

    Solari Active Member

    Is there something I need to toggle somewhere so when someone is tagged @Name in a forum it's supposed to alert them? Thanks.
     
  2. Jeremy

    Jeremy XenForo Moderator Staff Member

    Verify the person who is tagging the other user has permissions. You'll find it under user group permissions. Make sure it is more than 0.
     
    a.tushkanov likes this.
  3. Solari

    Solari Active Member

    Where do I find this in permissions? What is it called? I can't seem to find it in the list. Thanks!
     
  4. Jeremy

    Jeremy XenForo Moderator Staff Member

    Edit a user groups permission, search the page for "tag" and it should find it. I don't know the exact wording off hand (however, it's one of the only numerical permissions).
     
  5. Solari

    Solari Active Member

    I did, the only results that come up for "tag" is:

    Maximum tag alerts per message (set to 5)
    Allow block tags (code, quote, etc): (in signature area)
     
  6. Jeremy

    Jeremy XenForo Moderator Staff Member

    The first permission is the correct one. Have you used the permissions analyzer to determine what the user is allowed to tag? Are the users not getting alerts the 6th + tag in a post?

    Was the post edited to include the tag?
     
  7. Solari

    Solari Active Member

    Yes, the user was allowed unlimited tags (because of higher level). It was a new post. He tagged me and I don't have anything else set to tag or alert me on the thread. I did the same to him and he didn't get anything as well.
     
  8. Solari

    Solari Active Member

    I also checked my own preferences and it shows allow alerts on user tags on.
     
  9. Jeremy

    Jeremy XenForo Moderator Staff Member

    Can you reproduce this with add-ons disabled?
     
  10. Solari

    Solari Active Member

    Yes, it still doesn't work with all add-ons disabled.
     
  11. Solari

    Solari Active Member

    Also switched to default theme and still no go.
     
  12. Jeremy

    Jeremy XenForo Moderator Staff Member

    Have you modified any files? Can you run a file health check.
     
  13. Solari

    Solari Active Member

    Yes, we modified these two per the file health check, which is all showed up. Those two we slightly modified to remove login box to redirect to a different one (integrated with wordpress).
    1. library/XenForo/ControllerPublic/Logout.phpFile does not contain expected contents.
    2. library/XenForo/ControllerPublic/Login.phpFile does not contain expected contents.
     
  14. Jeremy

    Jeremy XenForo Moderator Staff Member

    Neither file deals with alerts. How did you disable your add-ons?
     
  15. Solari

    Solari Active Member

    I went to the home admin page where you see the installed add-ons in the lower right and unchecked. I noticed they were gone from the forums so I know it turned them off.
     
  16. Jeremy

    Jeremy XenForo Moderator Staff Member

    Can you retest by disabling listeners via the configuration file? Paul's FAQ threads include the code you need to add.
     
  17. Solari

    Solari Active Member

    Okay, that sounds scary lol. ; ) It may be over my head, I'll wait and see if my developer can figure out what you meant. Thanks!
     
  18. Jeremy

    Jeremy XenForo Moderator Staff Member

    If you send me the following pieces of information via PC I can look into a few things and run a few tests:
    • phpMyAdmin access (DB access)
    • FTP access
    • Admin details and a test account
     
  19. eagle eyes

    eagle eyes Active Member

    The user posted the tag must have mention ability to mention more than 0 times. Just increase it from 0, most likely thats what it is.
     
  20. Jeremy

    Jeremy XenForo Moderator Staff Member

    He's verified permissions are correct a few posts above.
     

Share This Page