1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Not a Bug User Auto Banned

Discussion in 'Resolved Bug Reports' started by VinnyS, Aug 24, 2013.

  1. VinnyS

    VinnyS Active Member

    Hi
    Just caught a spammer, great trying to delete the account and I'm getting an error I have attached what I am see after I press delete. I am using the latest version of XenForo. Could someone help me in this matter.

    Thank You
     

    Attached Files:

  2. Brogan

    Brogan XenForo Moderator Staff Member

    A 500 error is generic so is difficult to debug.

    Is there anything in the ACP error log?
    Also check the server error log.
     
  3. VinnyS

    VinnyS Active Member

    Hi Sorry here is the server report hope this helps..

    Server Error Log
    Error Info
    ErrorException: Fatal Error: Call to undefined method XfAddOns_Groups_LikeHandler_Post::batchUpdateContentUser() - library/XenForo/Model/User.php:2546
    Generated By: VinnyS, A moment ago
    Stack Trace
    #0 [internal function]: XenForo_Application::handleFatalError() #1 {main}
    Request State
    array(3) { ["url"] => string(63) "http://sociallivingtoday.com/admin.php?users/perrylund.3/delete" ["_GET"] => array(1) { ["users/perrylund_3/delete"] => string(0) "" } ["_POST"] => array(2) { ["_xfConfirm"] => string(1) "1" ["_xfToken"] => string(8) "********" } }
     
  4. Mike

    Mike XenForo Developer Staff Member

    That's from an add-on -- whatever add-on creates XfAddOns_Groups... classes.
     
  5. VinnyS

    VinnyS Active Member

    Hi Mike

    I though this may have been the problem and I am uninstalling the add-on's as we speak. After I uninstall the add-on's I will try to delete the user again. I will let you know what happens. Thank You for the quick response.
     
  6. VinnyS

    VinnyS Active Member

    Hi Mike
    OK uninstalled what I thought might be giving me the problem, however Im still getting this error. Question should I remove the files from the server or re-download a copy of XenForo and do a re-install of the software?

    ErrorException: Fatal Error: Call to undefined method XfAddOns_Groups_LikeHandler_Post::batchUpdateContentUser() - library/XenForo/Model/User.php:2546
    Generated By: VinnyS, A moment ago
    Stack Trace
    #0 [internal function]: XenForo_Application::handleFatalError() #1 {main}
    Request State
    array(3) { ["url"] => string(63) "http://sociallivingtoday.com/admin.php?users/perrylund.3/delete" ["_GET"] => array(1) { ["users/perrylund_3/delete"] => string(0) "" } ["_POST"] => array(2) { ["_xfConfirm"] => string(1) "1" ["_xfToken"] => string(8) "********" } }
     
  7. Jeremy

    Jeremy XenForo Moderator Staff Member

    Do you have any any Group related add ons? The error is most definitely generated by an add on.
     
  8. VinnyS

    VinnyS Active Member

    Hi Jeremy
    I took them out they were the ones for group forums, however I did not like them and uninstalled them. Now with that said I did install two bought ones for user groups and one for blogs running about $40.00 a piece that would stink if they are the cause.
     
  9. Jeremy

    Jeremy XenForo Moderator Staff Member

    It's most likely the user groups add on, since it's dealing with users.
     
  10. VinnyS

    VinnyS Active Member

    Hello Everyone
    I just tried something I disabled the Add-On and I was able to delete the user? I also made the author Rigel Kentaurus of the Social Group Add-On aware of the problem. Again Thank You everyone for the quick response the other day.
     

Share This Page