1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Use Full Friendly URLs

Discussion in 'Troubleshooting and Problems' started by audiokid, Jan 18, 2015.

  1. audiokid

    audiokid Active Member

    When Use Full Friendly URLs is selected, the popup for Members Online Now, no longer works.
     
  2. Amaury

    Amaury Well-Known Member

    Which popup are you referring to?
     
  3. audiokid

    audiokid Active Member

  4. audiokid

    audiokid Active Member

    NOTE, I'm referring to my site when I activate Use Full Friendly URLs

    Its actually been this way for many versions.
     
  5. Amaury

    Amaury Well-Known Member

    There is no overlay for Members Online Now. The link takes you directly to the Current Visitors page.

    Sounds like an issue with your style, in which case you'll need to post in the appropriate forum for support or in the style thread if it's a third-party style.
     
  6. audiokid

    audiokid Active Member

    Its been like this since I got Xenforo. I use the stock style. If I don't use the friendly URL's it pops up. If I do, its a dead link.
     
  7. audiokid

    audiokid Active Member

    Pops up fine here. I bet it they activated the friendly URL's it would do the same.
     

    Attached Files:

  8. Mike

    Mike XenForo Developer Staff Member

    Can you set your site up such that we can reproduce the issue?
     
    Amaury likes this.
  9. Amaury

    Amaury Well-Known Member

    They do have friendly URLs enabled here.
     
  10. audiokid

    audiokid Active Member

    I would but I don't want the urls indexed unless I keep them like that. It also throws a few links into page errors
    But are the "Full" Friendly URL's?
     
  11. Tracy Perry

    Tracy Perry Well-Known Member

    Uh... pretty sure they are...
    At least the appear similar to mine

    Screen Shot 2015-01-18 at 3.22.25 AM.png Screen Shot 2015-01-18 at 3.22.48 AM.png Screen Shot 2015-01-18 at 3.23.00 AM.png

    It's something specific to your site. Have you tried it with add-ons disabled?
     
  12. Steve F

    Steve F Well-Known Member

    When you enable Friendly URLs ensure that you have the .htaccess file in place, stock XenForo ships with it named "htaccess.txt". It needs to be ".htaccess" with Friendly URLs enabled.
     
  13. Tracy Perry

    Tracy Perry Well-Known Member

    Only if you are running Apache or LiteSpeed. ;)
    OpenLiteSpeed and nginx are different.
     
    Steve F likes this.
  14. audiokid

    audiokid Active Member

    Yup, htaccess works fine. URL friendly works fine on my site, FULL url does too, except for the popup as I described in the open post. ;)
     
  15. Tracy Perry

    Tracy Perry Well-Known Member

    That's the member card... you need to see if you have any add-ons that modify the template for it (or if you have modified the templates).

    Is this what you are talking about not popping up if it's enabled?

    Screen Shot 2015-01-18 at 2.25.25 PM.png
     
  16. audiokid

    audiokid Active Member

    Okay, I'm assuming if we don't see an index.php in the thread then its Full friendly, yes? Then Xenforo is using full here?
     
  17. Brogan

    Brogan XenForo Moderator Staff Member

    Can you give guests permission to view members and also enable friendly URLs so we can see the issue?
     
  18. audiokid

    audiokid Active Member

    Thanks for chiming in Tracy,
    If I create a new parent style, this should tell me more then, correct?
     
  19. audiokid

    audiokid Active Member

    Okay, stand by...
     
  20. Tracy Perry

    Tracy Perry Well-Known Member

    I'm about to head out to see American Sniper. If you want to shoot me a Skype (contact is in my profile) in about 3 hours I can take a look at it.
    In the mean time, real quick enable FURL. If it's not working on the members online, then it shouldn't work for the new member either.
     

Share This Page