1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Use Full Friendly URLs option not working

Discussion in 'Installation, Upgrade, and Import Support' started by gginni, Apr 20, 2013.

  1. gginni

    gginni Active Member


    When I check "Use Full Friendly URLs" option and try to browse my forum then I'm getting error page..

    Can anyone tell me what should be the content of .htaccess file for this option to work?
  2. Brogan

    Brogan XenForo Moderator Staff Member

  3. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Possible causes of friendly URLs not working (usually manifests as "404 not found" error on forum pages):

    1) The .htaccess file is not in place in your forum directory.

    2) Sometimes you need to specify RewriteBase in your .htaccess file (specify the name of your forum directory):

    RewriteBase /xenforo

    3) Your server doesn't have mod_rewrite installed. Consult with your host about this.

    4) Your server doesn't have AllowOverride enabled:


    Consult with your host about this.
    Carlos Oporto likes this.
  4. gginni

    gginni Active Member

    Well it is working but with wordpress as my home page it is creating problems.. I have wordpress in outer directory with .htaccess file in wordpress. That .htaccess file have below content:-

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    # END WordPress
    And then I have forum directory and .htaccess within that forum directory. .htaccess file within forum directory have below content:-

    #    Mod_security can interfere with uploading of content such as attachments. If you
    #    cannot attach files, remove the "#" from the lines below.
    #<IfModule mod_security.c>
    #    SecFilterEngine Off
    #    SecFilterScanPOST Off
    ErrorDocument 401 default
    ErrorDocument 403 default
    ErrorDocument 404 default
    ErrorDocument 500 default
    <IfModule mod_rewrite.c>
        RewriteEngine On
        #    If you are having problems with the rewrite rules, remove the "#" from the
        #    line that begins "RewriteBase" below. You will also have to change the path
        #    of the rewrite to reflect the path to your XenForo installation.
        #RewriteBase /xenforo
        #    This line may be needed to enable WebDAV editing with PHP as a CGI.
        #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
        RewriteCond %{REQUEST_FILENAME} -f [OR]
        RewriteCond %{REQUEST_FILENAME} -l [OR]
        RewriteCond %{REQUEST_FILENAME} -d
        RewriteRule ^.*$ - [NC,L]
        RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
        RewriteRule ^.*$ index.php [NC,L]
    If I delete the .htacess file which is in outer directory then Use full friendly URL option works fine but after deleting wordpress htaccess, my wordpress URLs like pagination stops working. And if I don't delete that then Use full friendly URL option doesn't work. Any thread click redirects me to home page which is my wordpress.

    Please guide me what should I do?
  5. Tracy Perry

    Tracy Perry Well-Known Member

    Try uncommenting the RewriteBase /xenforo.
    Jake Bunce and gginni like this.
  6. gginni

    gginni Active Member

    Tracy Perry likes this.
  7. Tracy Perry

    Tracy Perry Well-Known Member

    Have you checked to see if it is working correctly now that you changed the rewritebase?
  8. gginni

    gginni Active Member

    Yes bro checked now and still not working:-

    I get error that:-

    The requested page could not be found.

Share This Page