1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Use Friendly URL's Error

Discussion in 'XenForo Questions and Support' started by TazDevilLooney, Nov 29, 2010.

  1. TazDevilLooney

    TazDevilLooney Active Member

    Hi people, i've just brought the product today and have installed it with no problems.
    When i use the [Full Friendly URL's] and click on a forum i get a Internal server Error.
    The home page and admin displays correctly with the setting on but problems with the forums.

    This is the address it's sending me to - http://mysite/forums/my-forum.5/

    I'm using the .htaccess which came with the package with no alterations.

    Any idear?

    Thankyou Taz
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    That URL looks correct to me assuming you installed it in the root?

    Is there anything in the error log?
     
  3. TazDevilLooney

    TazDevilLooney Active Member

    Thankyou for the quck replay Brogan,

    The Xenforo log contains no errors.

    My serve log conatins this

    [Mon Nov 29 14:26:20 2010] [error] [client 127.0.0.1] Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace., referer: http://mysite.com/

    Works ok with the option off :)
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

    Is your forum installed in the root or a sub directory?

    Do you have anything else in your .htaccess file?
    It sounds to me like you have conflicting rewrite settings.
     
  5. TazDevilLooney

    TazDevilLooney Active Member

    Installtion is the the root directory

    and his is the contents of the .htaccess file

    <IfModule mod_rewrite.c>
    RewriteEngine On

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -l [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^.*$ - [NC,L]
    RewriteRule ^(data|js|styles|install) - [NC,L]
    RewriteRule ^.*$ index.php [NC,L]
    </IfModule>

    I'm not sure whats going on as i use .htaccess for my other sites.
     
  6. TazDevilLooney

    TazDevilLooney Active Member

    I got it.

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -l [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^.*$ - [NC,L]
    RewriteRule ^(data|js|styles|install) - [NC,L]
    RewriteRule ^.*$ index.php [NC,L]
    </IfModule>

    :)
     
  7. TazDevilLooney

    TazDevilLooney Active Member

    Yes

    Apache 2.2.16
    php 5.3.3
    MyQSL 5.1.50-community
    MySQL client version: mysqlnd 5.0.7-dev - 091210 - $Revision: 300533 $
    MySQL charset: UTF-8 Unicode (utf8)
    phpMyAdmin 3.3.6
     
  8. Blandt

    Blandt Well-Known Member

    So is it working now ?
     
  9. TazDevilLooney

    TazDevilLooney Active Member

    It is indeed, just need to add

    RewriteBase /

    to the .htaccess and away it went.


    Cheres, no doute ill have more questions. hehe
     
  10. Mike

    Mike XenForo Developer Staff Member

    Are you doing some sort of redirection in Apache?

    While we can't add this line by default, we can put it in with a comment to use it if you get errors.
     
  11. Brogan

    Brogan XenForo Moderator Staff Member

    Interesting, thanks for posting back with the solution.

    I haven't seen that crop up before so it's worth bearing in mind for the future.
     
  12. TazDevilLooney

    TazDevilLooney Active Member

    I am hosting 3 sites of the same server in diffrent dirs (Residental Server) using no-ip for the redirection.
    I don't relly know what the norm is as i've always used this type of software.

    The comment would give customers something else to try if they get errors. Nice idear!
     

Share This Page