• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 Upload error

Jaws

New member
#1
Another problem tonight..
Anyone trying to upload a file gets an error, and honest truth.. I aint got a clue !!

ErrorException: copy(/home/superblackbird/public_html/internal_data/attachments/21/21832-1bd61a85502ab251fc0e42c3ff58063a.data): failed to open stream: Permission denied - library/XenForo/Helper/File.php:261
array(3) { ["url"] => string(120) "http://superblackbird.co.uk/index.p...0e3841d0958ccc41ee9f61f17b1&content_type=post" ["_GET"] =>
array(3) { ["attachments/do-upload_json"] => string(0) "" ["hash"] => string(32) "2e4720e3841d0958ccc41ee9f61f17b1" ["content_type"] => string(4) "post" }
["_POST"] => array(13) { ["_xfToken"] => string(8) "********" ["_xfNoRedirect"] => string(1) "1" ["_xfResponseType"] => string(4) "json" ["_xfSessionId"] =>
string(32) "d5f3117be033eef12571d4984cf8ad04" ["content_data"] => array(1) { ["thread_id"] => string(5) "74854" } ["flowChunkNumber"] => string(1) "1"
["flowChunkSize"] => string(10) "4294967296" ["flowCurrentChunkSize"] => string(4) "6890" ["flowTotalSize"] => string(4) "6890" ["flowIdentifier"] => string(13) "6890-clangjpg"
["flowFilename"] => string(9) "clang.jpg" ["flowRelativePath"] => string(9) "clang.jpg" ["flowTotalChunks"] => string(1) "1" } }
 

Brogan

XenForo moderator
Staff member
#2
This is typically a permissions issue on the server.

Contact your host and ask them to ensure the data and internal_data directories are recursively chmod to 0777.

If it isn't that, try chowning.

If that doesn't work, it could be SELinux.
 

Jaws

New member
#3
Many thanks for the info
Could you puppy walk me through it please.. A few years ago I was head of IT for Durex ( really :) ) but had a stroke in may and am like a total newbie
 

Brogan

XenForo moderator
Staff member
#4
If you have an FTP application, you can usually set permissions there.

Connect to the server and right click on the directories and an option to set the permissions should appear.

There should also be a checkbox to do it recursively.
 

Jaws

New member
#5
Morning Brogam,
all the permissions were set to 755... Tried to set them to 777 and while it goes through the motions, when it is finished they are all still 755 or in some case 655.. Any idea ?