1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Upgraded to 1.2.4 today

Discussion in 'General XenForo Discussion and Feedback' started by Bionic Rooster, Dec 17, 2013.

  1. Bionic Rooster

    Bionic Rooster Well-Known Member

    First time upgrading and I must say it was smooth and painless. Thanks guys for all the hard work to make our work easier.
    Adam Howard likes this.
  2. nodle

    nodle Well-Known Member

    All went smoothly here also. No problems. Also thank you to @Arty for always releasing updates so fast! (y)
    Adam Howard, Shyuan and Arty like this.
  3. NixFifty

    NixFifty Well-Known Member

    Fast and painless updates, what more could you ask for :D
    Adam Howard likes this.
  4. Jaxel

    Jaxel Well-Known Member

    I have noticed one glaring issue that wasnt mentioned...

    All header text (sidebar headers, navbars, subnavs, etc) used to be bold in the previous version. Now they are not.
  5. Mike

    Mike XenForo Developer Staff Member

    You can look at the CSS changes (and no style property changes). Absolutely nothing changed there...
    Adam Howard and psx like this.
  6. Carlos

    Carlos Well-Known Member

    I noticed that too! Nice job @Arty! :)
    Adam Howard likes this.
  7. Craigr

    Craigr Active Member

    Yes went well here too and upgraded from 1.1 within minutes after i had uploaded the files correctly. :)
    Adam Howard likes this.
  8. Alien

    Alien Well-Known Member

    Another flawless upgrade! Timed it this time! Took 100 seconds to upload zip, unzip files, move files to live install, run upgrade script, merge 1 template (page_container) AND PEE! HA!

    Thanks crew!
    Adam Howard likes this.
  9. Adam Howard

    Adam Howard Well-Known Member

    Upgraded someone from 1.0 to 1.2.4 without issue. (y)

    Plan on upgrading mine sometime today or tomorrow (when I have the free time).
  10. Divvens

    Divvens Well-Known Member

    Also updated from 1.2.3 to 1.2.4 today, was smooth as usual. After upgrade ACP has some errors logged related to deferred. I deleted it instead of being smart and posting it here... but it was just during uploading files so I ignored it.

    Upgrading xenForo is always simple and fun, never do you have the fear of anything going wrong.
    Adam Howard likes this.
  11. whynot

    whynot Well-Known Member

    The Devil Never Sleeps.
    Adam Howard likes this.
  12. DRE

    DRE Well-Known Member

    I upgraded today. Will see what changes I have to make later.
    Adam Howard likes this.
  13. DRE

    DRE Well-Known Member

    No changes needed.
    DarkGizmo likes this.
  14. feldon30

    feldon30 Well-Known Member

    Upgraded from 1.2 to 1.2.4 without even doing a DB backup. Foolish I know, but that just tells you how confident I am in the software that I didn't even think to backup. ;)
    Adam Howard and whynot like this.
  15. Carlos

    Carlos Well-Known Member

    It's not foolish, man. I do the same. I have every confidence in KMA. :)
    Adam Howard likes this.
  16. myco-tek.org

    myco-tek.org Member

    I must admit I just did the same - system upgrade w/o a db backup... My host does automated backups ever 2 hours though so even if something didn't I would have been able to recover virtually everything anyway. Everything went smoothly regardless. :)

    The whole thing only took 6 minutes!
    Adam Howard likes this.
  17. DarkGizmo

    DarkGizmo Active Member

    I upgraded yesterday, just had to merge 2 templates, nothing broke, no real changes done just a few functionality things i think with the two templates, but overall, painless upgrade! :D
    Adam Howard likes this.
  18. SiteOwner

    SiteOwner Member

    I upgraded my site on localhost. Easy like 123.
  19. feldon30

    feldon30 Well-Known Member

    I was still in the vB mindset, so :
    • I made a list of every modified template
    • I went through the XF 1.2.1, 1.2.2, 1.2.3, and 1.2.4 release notes and saw which ones would be affected
    • I copy-pasted all my customized templates to a text file
    • I ran the 1.2.4 install.
    • I expected to have to revert those templates and then pick through and figure out what changed and make my same changes again.
    Instead, I just reviewed the changes, merged the template changes with the click of a button and it worked perfectly. All told, it was like 10 clicks to upgrade from XF 1.2 to 1.2.4.
    Last edited: Dec 23, 2013

Share This Page