1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Upgrade gone wrong?

Discussion in 'XenForo Questions and Support' started by TDUBS, Oct 16, 2014.

  1. TDUBS

    TDUBS Active Member


    I upgraded my forum to the latest which was released today. After doing so, I noticed everything pretty much went non-functional. I tested it on the default theme as well just to make sure it wasn't a theme issue, and it did the same there. Things I instantly noticed;

    - Forum loads really slow.
    - You cannot reply to threads (the reply space is completely gone).
    - No dropdown menu works. You can click it as normal, but when hovering - nothing comes down.

    When I went to /install to upgrade, it didn't automatically go through the process.. I had to click "continue" multiple times until the end. I used Filezilla to upload/replace/overwrite the files for upgrade.

    Any ideas?

    Last edited: Oct 16, 2014
  2. BoostN

    BoostN Active Member

    Hopefully you have a backup.

    First, I would try to re-upload the files and try again.
  3. New Joe

    New Joe Active Member

    Sorry to hear that.
    I usually wait a while, maybe a month before upgrading to watch out for any problems with latest versions.
    Hope you get yours sorted soon
  4. Mike

    Mike XenForo Developer Staff Member

    Errors like this usually imply that the files haven't been uploaded correctly, and indeed I'm not seeing the complete content for xenforo.js. Try reuploading all of the files.
  5. TDUBS

    TDUBS Active Member

    I've tried replacing the files, and that didn't work. I even went as far as going into each individual folder/sub-folder from the upgrade download and manually replaced everything and it still didn't work. I'm currently running my last backup, so hopefully that works. I'll probably hold off for a while before upgrading. It's a shame because I've never had this issue before and I've been using xenForo for quite a while now.
  6. Mike

    Mike XenForo Developer Staff Member

    Run the file health check in the control panel and see what that reports.
  7. TDUBS

    TDUBS Active Member

    I did that and it reported all required files were there. I ran my backup and everything works fine except now when I access my forum it says "The board is currently being upgraded. Please check back later."
  8. AndyB

    AndyB Well-Known Member

    Admin CP -> Options -> Board Active -> Board is Active (check this and click Save Changes)
    TDUBS likes this.
  9. New Joe

    New Joe Active Member

    So I was just wondering if all was ok now.
    Going to do my upgrade soon and want to make sure there will be no issues....
  10. rainmotorsports

    rainmotorsports Well-Known Member

    Normally there are never any issues. You won't know until you try. Make a backup. I have 60 something addons and just none of the ones that have ever caused a problem and never had a bad upgrade even in beta's. Other people 1 addon and no backup, life destroyed. Plan, Test, have a backup.
  11. Mike

    Mike XenForo Developer Staff Member

    Based on his other thread, this was unrelated to XenForo. It was a misbehaving reverse proxy.
  12. Chris D

    Chris D XenForo Developer Staff Member

    The only known issue was with the User Essentials add-on. If you have that, install the latest version before doing the XF upgrade.
  13. TDUBS

    TDUBS Active Member

    Yes. Everything went fine after 4 days of constant uploading of my backups and trying different methods to get it working. Finally after so, I'm pretty sure it was the reverse proxy I was using. Once I removed that and paused CloudFlare (only paused it because their upload size is 100MB for free users), everything worked.

Share This Page