• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Upgrade from 1.1 to 1.2 doesn't work normally

#1
Hi there,

the readme Text in the Upgrade package is not correct , because it runs in that error that you cant upgrade because it is the normal install process.

Code:
Once the files are uploaded, your XenForo installation will automatically be closed
until the upgrade is complete. To begin the upgrade, go to the URL that corresponds
to <your XenForo Directory>/install (eg: http://www.example.com/xenforo/install).
You will be instructed to login as an administrator and guided through the steps.
Once the upgrade is complete, your XenForo installation will automatically be reopened.
is the corresponding text. But thats not correct. So you start the install not the upgrade.

Upgrading works with : http://www.example.com/install/index.php?upgrade
And that works like a peace of candy :D


Regards
Oliver
 

Mike

XenForo developer
Staff member
#2
If that URL isn't triggering the upgrade system automatically, then you probably wiped out the install lock file, which happens if the files aren't uploaded correctly. (Specifically, you need to be sure to merge directories.)
 

justwordme

Active member
#5
I use Core FTP and just drag from my computer and drop onto server. I then overwrite when prompted super easy for this n00b. Sounds like merge is the same process. Thanks.
 
#6
If that URL isn't triggering the upgrade system automatically, then you probably wiped out the install lock file, which happens if the files aren't uploaded correctly. (Specifically, you need to be sure to merge directories.)
Of cause i delete the install directory after the first install of Xenforo 1.1 . why ? Because secure a folder with htaccess for user and PW is not strong enough? To easy for Stupid script kids.
and in the install / Upgrade Readme is nothing about a install.lock file. upgrade is not install imho. BTW, backups before upgrade is the first :)

And i know what file and directory merging is. just make a choice at the beginning : Install new or Upgrade from. Then it doesn't care about a file named install.lock
 

Divvens

Well-known member
#7
Of cause i delete the install directory after the first install of Xenforo 1.1 . why ? Because secure a folder with htaccess for user and PW is not strong enough? To easy for Stupid script kids.
and in the install / Upgrade Readme is nothing about a install.lock file. upgrade is not install imho. BTW, backups before upgrade is the first :)

And i know what file and directory merging is. just make a choice at the beginning : Install new or Upgrade from. Then it doesn't care about a file named install.lock
You can always password protect the install directory + add only certain IP's from accessing the install directory. You also have to have an admin account to actually do anything on that page, as far as I know it's suggested that you always keep the install directory and don't delete it.