1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 Trying to remove +0000 from RSS Feed pubDate

Discussion in 'Troubleshooting and Problems' started by Martyn, Dec 24, 2015.

  1. Martyn

    Martyn Active Member

    Would anyone know how to remove the +0000 part from the RSS feed, I guess its the location part?

    many thanks

    example of rss feed time stamp

    <pubDate>Thu, 24 Dec 2015 01:43:26 +0000</pubDate>
  2. Mike

    Mike XenForo Developer Staff Member

    You can't really remove it. It's part of the date format required by the RSS specification.
  3. Martyn

    Martyn Active Member

    "really" :p so there must be something I can do to hide it? RSS feeds from the forums to an external page just seem.. not a nice look =-/

  4. Martyn

    Martyn Active Member

    I'm using smarty to (rss feed is on whmcs)

    I've found this {$item->pubDate|date_format:'%e %B %Y'} but that doesn't work >.<, unsure if you know?

    Was originally pulling the date via {$a->pubDate}
  5. Chris D

    Chris D XenForo Developer Staff Member

    The format of the date is solely down to the client. For consistency the RSS spec requires it to be the format we use, but clients may format that how they wish. With that in mind, it's a support query better directed at whoever provides the client.

    That said, if it was using $a before then presumably you would need to use $a instead of $item.
  6. Martyn

    Martyn Active Member

    Ah thanks for pointing that out! late night early morning. many thanks! :)

Share This Page